Budget Main Window

The main window has 7 sections, Accounts, Envelopes, Envelope Views, History, Statistics, Transaction
Entry, and Settings. The Account, and Envelope sections are always shown, the others may be configured to
show or not. Drag the dividers left/right
or up/down
to resize any section. Dragging a section to it's
far edge will collapse the section. You can also show or hide a section using the buttons in the bottom border
of the window.

The Account section shows a list of your accounts
Selecting an account will show the associated envelopes and envelope balances for that account. Selecting a
bank account shows it's history in the history section if no envelope is selected. Selecting the Total box
deselects all accounts and shows the envelopes net balances for all accounts. See the section Bank Accounts
for more information on how to create and work with accounts, or the Associated Envelopes for more
information on associated envelopes.

The Envelope section shows a list of your envelopes
The envelope section shows the envelopes associated with the selected bank account or all envelopes if the
"Total" box is selected. Selecting an envelope displays it's transaction history in the History section and it's
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statistics in the Statistics section. See the section Envelopes for more information on how to create and work
with envelopes.

The Envelope View section determines how your envelopes are displayed
The All Envelopes List shows all envelopes associated with a selected account or all envelopes if the "Total"
box is selected. Selecting a list shows the envelopes in that configuration. To create a new Envelope View
click the plus (+) button in the lower left of the main window. To delete an Envelope View select it and use
the Envelope menu and select Delete Envelope View. For more information see the Envelope Views section.

The History section
The History section shows either all transactions if no account or envelope is selected, the account history if
an account is selected and no envelope is selected, or the envelopes history if an envelope is selected.
Transactions are shown for the date range specified. For more information see the History section. Note:
setting a date range also controls the date range for the statistics section

The Statistics section
The Statistics section displays either the budget statistics if no account or envelope is selected, or the
envelopes statistics if an envelope is selected. Statistics are shown for the date range specified in the History
section. The statistics are shown in either a "Table ", "Line Graph ", or "Bar Graph ", format depending on
the setting in the "Settings " section. Note the day of the month is ignored. For more information see the
Statistics section.

The Transaction Entry section
The Transaction Entry section allows you to create transactions and work with your reminders. Selecting
accounts and/or envelopes on the main window determine the settings of the popups. For more information
see the Transaction Entry section.

The Settings section
The setting section allows you to tailor how information is displayed on the main window. For more
information see the Settings section.
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Main Window Settings

Envelope View Area
The left side of the settings area is the envelope view table. All envelopes are displayed in the table and the
checkboxes are set based on the currently selected envelope view. Check the boxes to either show or hide the
envelope from the envelope view.
Note: You must select an account to modify an envelope view. You can not modify any envelopes in the
"All Envelopes" view.

History Area
Normally account histories only show transactions that effect multiple envelopes. Check the box to show all
transactions for an account. You can select which transactions types are shown in the history and transaction
report.

Transaction/Calendar Area
The top part shows information for a selected reminder. You can change the warning period or the frequency
of a reminder. Click the button to skip a due reminder. In the bottom part you can set whether Budget defaults
transaction information when you change accounts or envelopes. Check the box if you want to work with To
Do's in the calendar area.

Statistics Area
Select if you want Budget to display the statistics as a table, line graph, or bar graph. Check the boxes for the
type of information you want to see in the statistics.
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Using Budget Help
Budget has extensive help features. To get help use Budget's Help > Budget Help menu command. The
Budget help content will be displayed in Apple's Help Viewer.
In the Budget documentation, menu commands will be shown like this Menu name > Selection... and
specific BUTTON NAMES will be capitalized and in italics.
The toolbar at the top of Help Viewer has an area for you to enter a question and then click the ASK button.
This will search the Budget documentation for relevant topics and display them in a list in the bottom section.
You can then click on any of the results to go directly to that documentation.
The left side of each documentation page has links to sections of the Budget documentation. To use the help,
just click on one of the section links and its content list will be displayed. Then click the topic that matches
the type of help you need. The specific help information for that topic will be displayed on the right side of
the page.
Budget also has a ? button on most of the windows in the application itself. Clicking on this button will bring
you directly to the documentation page needed to learn how to use that window.

Tech Support
You can contact Tech Support by using Budget's Help > Email Tech Support menu command. This will
bring up your email application with our tech support address <support@snowmintcs.com> and some basic
information about the version of Budget you are using already filled in. Enter your question or comment and
send it to us. We try to respond to each email within 24 hours.
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The Envelope Model
A simple illustration of the envelope method is how your grandparents may have maintained a budget before
checking accounts were commonly used. They cashed their paycheck and distributed their money into real
paper envelopes marked with the name of the bill or expense, i.e., electricity, food, rent, etc. At the end of the
month when a bill came due, the money was in the envelope to pay it. It was a simple but effective way of
ensuring that their bills were paid and that they lived within their means.
Now that mostly everyone has a checking account its easy to lose sight of how much you can afford to spend.
Do you know if you have enough in your checkbook to pay your bills? Do you find out too late that you spent
more than you could afford? How about when the bi-annual insurance bill comes due — do you have the
money to pay it? With Budget you can set aside money in your checkbook into virtual envelopes for all your
expenses.
How Budget Uses Envelopes
With Budget, the main focus is on your envelopes. You will create virtual envelopes for your expense
categories and distribute your checking account money into those envelopes. When the mortgage bill needs to
be paid, you will write the check from the "Mortgage" envelope. If you receive a claim reimbursement from
your health insurance, you can make a deposit into the "Medical" envelope. When you get paid, you will
distribute the deposited income to your envelopes to fill them up again.
Your envelopes, and their balances are always displayed on the main screen, so you will know at a glance if
you have enough money to pay the bills — it's a lot easier than opening up real envelopes to see what's
inside! You can even look at an envelope's history to see all prior transactions. It's like having a checkbook
for each envelope!
Budget is also an account manager. You can manage your real world checking or savings account at the same
time as you're managing your budget. Record transactions, print checks, view your checkbook register
(account history in Budget' terminology), and balance your checkbook each month using Budget. You can
even track your credit card accounts.
The real power of Budget is the ability to set up your budget plan in advance and preallocate future income
deposits directly to your envelopes when you get paid. You'll find it easy to stick to your budget when you
pay your budget first.
Budget is Powerful or Simple - you Decide
You don't have to use all the features of Budget to use the program. For example, you can simply track your
expense money without tying it to your real world account — kind of like just replacing those physical
envelopes you may be using. Or you can distribute your pay deposits manually to your envelopes without
setting up pay allocations. Parents, Budget can even be used by your child to manage their allowance or your
teen to manage their part-time job income and expenses.
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What happened to my check register?
Your check register has been your basic way of seeing what's in your checkbook. It's simple and intuitive. In
fact it's the way most other money management and checkbook tracking software work. But ask yourself this
question, when I look at the bottom number how can I tell if there is enough money to pay my electric bill
and still buy that CD I want? The truth is, it's very difficult when looking at your checkbook balance to make
that determination.
Imagine if you had a separate checkbook for each bill you had to pay. That would make it very easy to know
if you had enough to pay each bill, but it would be a nightmare trying to keep the right amounts in each, not
to mention the problem of carrying them all in your pocket.
Budget solves this problem in a simple manner. If effectively turns your checkbook into lots of little
checkbooks. In fact, thinking about your envelopes in Budget as mini checkbooks is a good way to
understand how things work.
Example: You have created your "Mortgage" envelope and you have a mini checkbook that goes with that
envelope. You make deposits to it, write checks from it, and put money from your pays into it. You look at
the balance in this mini checkbook and know immediately if there is enough to pay the bill.
Budget handles the maintenance of all these mini checkbooks (envelopes) for you. You still have your single
real world bank account but now you can see where all your money is. And, by the way, you'll easily be able
to see if you have enough to buy that new CD you wanted.
You can still view your checkbook register in budget
Budget is unique in that it's main focus is on your budget rather than your checkbook register. However, you
can still easily view your checkbook register in Budget at any time. Select a bank account you want to work
with then click the HISTORY button on the toolbar. Check the SHOW ALL TRANSACTIONS box in the
resulting history window to display transactions exactly like a check register. Budget goes even further by
letting you also view the checkbook register for each of your mini checkbooks — just select the envelope and
click the HISTORY button in the toolbar.
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Keeping to a budget
The Budget program provides a number of ways to help you stick to your budget.
Knowing that you have allocated the proper amount to each of your envelopes insures that at the time the bill
is due there will be enough funds to cover the bill. As you allocated money to each envelope the program tells
you the remaining amount of your pay. This allows you to modify the allocations to each envelope to set up a
budget that you can actually live within.
The ability to easily see how much money is in each of your envelopes is the best way to keep to your budget.
If the envelopes show negative numbers you will realize very quickly that something is wrong. Likewise, if
the envelopes start to build up more money than necessary you can start trimming back that envelope and use
the money for other envelopes.
You can use the Budget Statistics function to see how well you are doing keeping to your budget. This
function provides information on how much you budget for an envelope and how much you actually spend
from that envelope.
There are also a number of reports that can be printed to record how well you are keeping to your budget.
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Saving Your Data File
To save your file use the File > Save... menu command or click the SAVE toolbar button. You will see the
standard save window if you decide to save the file.
Changes (recording transactions, etc.) made during your working session are only made in memory. This
means that until you save your work the changes you have made are not written to your hard disk. If you
attempt to quit the program or close the budget file you are working with you will see the save window. Click
SAVE CHANGES to write the data to the disk and save your work. Click DON'T SAVE to return to the same
data you had when you started the program. Click CANCEL to return to the main menu.

Backing Up Your Data
Remember, this is your financial data, ALWAYS MAKE COPIES OF YOUR DATA FILE FOR BACKUP.
Develop your own strategy and stick with it. One method is to save a copy of your budget data file each
month just after you balance your checkbook. That way you will always have a valid starting point if
something should go wrong during the month. We have made every effort to insure that Budget works
correctly. Budget includes a number of integrity routines that are constantly checking the data to insure its
correctness, however, errors can occur. Disks can crash, power can fail, and even the operating system can
have a bug.
The Budget program also provides an automatic backup feature. When you save a Budget file for the first
time the document is saved as usual. When you save a Budget file for the second time, the previous budget
file will be renamed as a backup file, and then the new data is saved in the new file.
When you save a Budget file any time after the first or second time, the previous backup file will be deleted,
the previous data file will be renamed as the backup file, and then the new data is saved in the new file.
If Budget is set to only keep one backup file (the default), the naming convention for the backup file is to put
a tilde (~) after the file name but before the .budget. So, "Our Budget.budget" has a backup file of "Our
Budget~.budget".You can use the Preferences window to set the location of this backup file.
Budget can also be set to keep dated backups which add the date to the file name instead of a tilde. In this
case, "Our Budget.budget" has backup files such as "Our Budget08-10-02.budget", "Our Budget08-11-02.
budget", etc. These backup files are only created once per day, so any later changes to the file will be backed
up on the next day that Budget is run. You can use the Preferences window to switch between the dated and
one file backup strategy.
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Handling Credit Cards
Handling credit cards with Budget is a matter of personal preference. You should strive to pay off your credit
card debt, and use your credit card as a simple convenience tool. Budget can help you do that by showing you
where you are spending money. There are three different methods you can use which vary in the amount of
detail you want to keep regarding your credit cards. The more detailed methods give you a better insight into
where you are spending money but require more effort on your part.
No Detail
Pros: Simple to use.
Cons: No information on where you are spending your money. Can not reconcile the credit card statement
with Budget. No payment options.
One method is to create an envelope for each credit card, and use it just like any other expense envelope. This
is the simplest way to pay the credit card bill but gives no insight into how the money is being spent. For
example, you would create an envelope named "Visa".
In your normal working bank account (the account that you will pay the credit card bill from), allocate money
to the credit card envelope from your pay as you would for any other bill. When the credit card bill comes
due, use that "Visa" envelope and pay the bill with a check or debit transaction.
With this method, there's no need to record finance charges or refunds. Simply pay the credit card bill when
it's due and ignore the parts that make up the bill.
Because you do not record each individual transaction on the credit card, you won't be able to tell where the
money was actually spent. You will know exactly how much money you're putting towards the credit card.
This method is sufficient if you have a credit card that you don't use anymore, but have an existing balance
you need to pay off.
Note: This same simple method can be used to pay off any loan. You'll be able to see exactly how much
money you're spending to pay back the loan. You will not be able to see how much more you owe, or what
you bought with the loan.
Some Detail
Pros: Moderately easy to use. Detailed information on where you are spending your money.
Cons: Can not reconcile the credit card statement with Budget. No payment options.
The second method to keep track of credit cards is to create an envelope for each credit card, and transfer
money into it as you use the card. For example, you would create an envelope called "Visa".
In your normal working bank account (the account that you will pay the credit card bill from), allocate money
to your various expense envelopes from your pay. Don't allocate any money directly to the "Visa" envelope.
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When you use the credit card to buy something, transfer money from the appropriate expense envelope into
the "Visa" envelope. To handle a credit card refund, transfer the amount back to the original envelope.
For finance charges, set up an envelope named "Finance Charges" or "Bank Fees". When you know the
amount of the finance charge, transfer that amount of money out of the "Finance Charge" envelope into the
credit card envelope.
When the credit card bill comes due, use that "Visa" envelope and pay the bill with a check or debit
transaction from your working bank account.
You can use the check mark feature in the envelope History window to help you reconcile your credit card
statement. Check each item on the statement with the items shown in the history list for the "Visa" envelope.
Click the checkbox to toggle the check mark on or off.
This method provides a degree of insight into where you are spending your money. Each of your expense
envelopes can count the transfers as expenses. With that option, your envelopes statistics will show how well
you are keeping to your budget.
Example: You buy $14.70 worth of gasoline for the car and use your Visa card to pay for the gas.
Transfer the $14.70 from your "Gas" envelope to your "Visa" envelope. The "Gas" envelope will reflect
the amount left in the gasoline budget and the "Visa" envelope will show the funds to be used when you
pay the Visa bill.
Complete Detail
Pros: Balance the credit card account when you get your statement using Budget, just like any other bank
account. Detailed information on where you are spending your money and your outstanding charges.
Cons: More complex to use. Money only gets transferred from your checking account envelopes when you
pay the bill, need to view "Total" box to view net amounts in envelopes.
The third method is to set up your credit cards as a bank account. You won't be setting up pay sources or pay
allocations for the Credit Card account.
When you use the credit card to buy something, you'll record a charge transaction to the credit card account
from the appropriate expense envelope. Since the charges are being recorded (as a negative number) in a
Credit Card account, they will not be deducted from the envelopes in your Checking Account until you pay
the bill. At that point, the negative amount in the Credit Card account envelope will be zeroed out, and the
amount will be deducted from your Checking Account envelope.
On the main screen, when you select the Charge Account, you'll see all the charged amounts shown as
negative amounts in your envelopes. When you select the Checking Account, you'll see the money in your
envelopes that is available to pay the charges. You can view the "net" amount in the envelopes by selecting
the Total box at the top left of the main screen.
For finance charges, set up an envelope named "Finance Charges" or "Bank Fees". When you know the
amount of the finance charge, record a charge transaction for that amount of money from the "Finance
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Charge" envelope using the credit card account.
When you receive the credit card statement, you can balance this account just like you would any other bank
account. All your charges will show up in the Balance Window for your credit card account.
To pay the credit card bill see the section on paying credit card bills. When you record this transaction
Budget will move money from the bank (checking) account to the credit card account in each envelope.
For more details on how to set up and use a Credit Card Account, see Getting Started Using Credit Card
Accounts.
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Handling Cash
There are a number of ways of handling cash from simple to very detailed. Three ways are described here.

No Detail
The simplest method of handling cash is to create an envelope called "Cash" and allocate money from your
deposits to this envelope. When you withdraw cash, record an ATM transaction out of this envelope. With
this method you will be able to see the amount used for cash. This method is very simple but lacks any real
detail on how the cash was spent.

Some Detail
A more detailed method is to create an envelope called "Cash", but don't allocate any money from your
deposits; leave the pay fields $0.00 when you create this envelope. When you take money from your bank
account for cash, deduct it from this "Cash" envelope and let the envelope go negative (cancel the Available
transfer that Budget automatically starts). As you spend the cash, transfer money from the proper envelope to
the "Cash" envelope (see also Transfer between envelopes).
Example: You have the "Cash" envelope, but you also have an envelope called "Entertainment" where
you record transactions for items such as tickets to a play. But you also want to track cash used for movie
tickets from the "Entertainment" envelope. First, you would need to insure that you were allocating
enough funds to the "Entertainment" envelope from your pay to cover both types of expense.
Lets say that you get $60 out of an ATM. When you record this ATM transaction in the Budget program
from the "Cash" envelope it shows a negative $-60. Now you spend $10 on a movie and you pay for it
with your cash. In the Budget program, you would transfer $10 from your "Entertainment" envelope to the
"Cash" envelope. The "Cash" envelope now shows $-50 which matches the $50 in cash you have in your
pocket.

This method provides a means of tracking the cash you spend, since each of the envelopes in your Budget
("Entertainment" in the above example) has recorded the transaction. The statistics function would show this
as an expense for Entertainment.

More Detail
Create a bank account and name it "Cash". This virtual account will represent the amount of cash you have,
and will contain all transactions regarding cash.
You don't need to set any pay source to pay into the Cash account, unless you are paid in cash (such as from
tips, etc), or you routinely cash your check immediately without putting it into a real world bank account. In
either of those cases you could have a pay source pay into the Cash account.
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When you withdraw cash from a real world bank account, in Budget you can transfer the money from that
bank account to the Cash virtual account. Just drag from one bank account to the other (see also Transfer
between bank accounts). At the top of the transfer window, the account on the left is the "from" account (the
checking account, for example) and the one on the right is the "to" account (the Cash account). You will need
to specify what envelopes you are affecting with this transfer. For example, you can use this to designate cash
being taken out for groceries, music, or whatever.
When you spend cash out of your pocket, you can record that in the "Cash" bank account and use a Debit
transaction.
Once in a while you can use the Balance command on the Cash account to make sure that the Budget records
match up with the amount of money in your pocket.
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Handling Savings Accounts
A savings account is just another form of bank account. Budget can track multiple savings accounts just like
it does checkbook accounts. Money in your savings account is distributed among your envelopes in the same
manner as for checkbooks.
Everything that you can do with a checking account in Budget can also be done with savings accounts. You
can even define pays for money to be distributed in your envelopes. For detailed information see the section
Working with multiple bank accounts.
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Budget Error Messages
Error messages in Budget normally indicate some sort of problem which is easily corrected.
Every effort has been made to make Budget as error proof as possible. However, it is impossible to predict
the configuration of every machine that runs the program. File system errors do occur, and they can cause
serious problems. It is extremely important that you back up your files on a regular basis. Run "Disk Utility"
and see if there are any problems with your hard drive. Notify tech support of any error messages you receive
that do not make sense to you.
Budget Tech Support email address: support@snowmintcs.com
Snowmint Web Forums: http://www.snowmintcs.com/forums/
Selection Errors
The first group of errors are selection errors. This means that the action you are trying to take requires you to
first select either an account or envelope with a single click of the mouse and then try the action again. Most
commands are disabled unless the proper items are selected.
Input Errors
Input errors are normally the result of typo's or not filling in a required field in a window. Budget will usually
hilite the bad entry and allow you to change it.
●
●
●
●
●
●

Balance Error.
The From field must be specified.
A valid envelope name must be specified.
A savings envelope may not be specified.
There are no shares in this account.
This transaction would cause your checkbook to go negative. That is not allowed.
Miscellaneous Errors

There are certain conditions that prevent you from executing an action such as trying to delete an envelope
that has unbalanced transactions pending. This would cause problems with the programs ability to correctly
balance your checkbook since some of the outstanding transactions would be missing.
●
●
●
●
●

This envelope can not be deleted.
You can't delete the "Available" envelope.
This envelope can not be deleted since it has Sub Envelopes.
This envelope can not be deleted since it has unbalanced transactions.
You can not create a sub envelope to the "Available" envelope.
Integrity Errors
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Budget is constantly checking for problems. Should they occur, the program will immediately inform you.
Integrity errors are displayed at any time the program has determined that it is unwise to continue. You
should quit Budget WITHOUT saving. The original file may still be valid, try restarting the program with
the file and see if the problem persists. If the problem persists you should contact tech support as soon as
possible. The integrity error may contain a code, if so, you should reference the code when you contact tech
support.
●
●
●
●

Integrity error 1. The total amount in all envelopes does not match the amount in the bank account(s).
Integrity error 2. The total amount of pay allocations to envelopes does not match your pay.
Integrity error 3. The pay distribution is invalid.
Integrity error 4. The most recent transaction in an envelope or bank account history does not match
the balance in that envelope or bank account.
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Note: If you have used personal finance programs that are based on the register model then Budget may
seem unintuitive and difficult to use. We suggest that you read the sections The Envelope Model and
Check Register first. This is the best way to understand how Budget works. If you are familiar with the
envelope model that Budget uses please continue below.

Getting Started With Budget
For new users
There are two ways to get started using Budget, the Setup Assistant or the manual method.
The Setup Assistant will guide you through the steps to set up your budget, and will streamline the effort it
takes to create accounts and envelopes and set up your budget file. If you are converting from a different
financial program you can import your data directly in the Setup Assistant. You can add, remove, or modify
anything you do in the assistant later using the normal program features.
If you'd rather use the manual method of getting started, click the CANCEL button to close the setup assistant
window. Using the manual method to get started may give you a better understanding of how the program
works since you will be using the normal Budget features and windows.

Importing Financial Data
Budget has the capability to import Quicken Interchange Format (QIF) and Open Financial Exchance (OFX)
files. This capability provides a means to access data from other financial programs or to access data from
financial institutions that have a QIF or OFX export capability. For more information, see the Import File
section.

For freeware Budget users
Budget for Mac OS X can read existing Budget data files that were created using the freeware versions
available for classic Mac OS (7.x - 9.x). Simply use the File > Open... menu command and navigate to your
existing Budget data file. The new Budget program does NOT write to existing freeware data files; therefore,
you will be required to save the file under a new name.
Registering Budget: When you purchase Budget you will receive a registration name and code. This
information must be entered into the program in order to enable additional features and stop the nag
screens from appearing. See the Registration section for more information.

Page 17 of 152

Using the Budget Setup Assistant
If you would rather use a manual method to get started, see the Manual Method help section. The setup
assistant streamlines the effort it takes to create accounts and envelopes and set up your budget file. You can
start a new budget file with the setup assistant at any time by using the File > New menu command.

Use the arrows at the bottom right of the assistant window to move through the steps. Clicking the question
mark button in the lower left will display information related to each step. You should have information
about your bank accounts, any regular income you receive, and expenses. The assistant steps are listed on the
left side of the screen.
Note: You will get a warning message if you attempt to quit the setup assistant before finishing. If you do
quit any information you entered so far will be lost. To save what you have done so far you should click
through to the end and then click the FINISH button.
Most steps allow you to create an object (like a bank account) by entering information and then clicking the
CREATE button. You can remove an object by first selecting it in the table (click it once) and then clicking
the REMOVE button. Other steps allow you to enter information directly in the table. To do that, double click
on the information in the table you want to change and enter the new information. The specifics of each step
are described below.
Note: You can add, remove, or modify any information that you enter in this setup assistant later in the
main program itself.

Import Data (Optional).
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Note: You will see the screen on the left if you are not using the Snowmint Creative Solutions Budget
Workbook application, otherwise, you will see the screen on the right.
If you have been using Snowmint Creative Solutions' Budget Workbook program and want to import your
workbook data into the Budget program as part of the setup process, click the IMPORT BUDGET
WORKBOOK DATA FILE button. If you are not using Snowmint Creative Solutions' Budget Workbook
program and want to import your QIF or OFX data from another program into the Budget program as part of
the setup process, click the IMPORT QIF or OFX DATA FILE button. When you import your data, a
statement of the total number of transactions and categories will be displayed. Your data will be used later in
the setup process to facilitate creating your envelopes and setting up your budget. Click the right arrow to
continue.

Setup Bank Accounts.
A bank account is your real-world checking account that you have at your bank that you want to track and
manage with Budget.
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Change "My Checkbook" to your bank account name, enter the amount of money that you currently have in
this bank account, and click the CREATE button. The information is now shown in the table at the top.
Note: Don't know what your current balance is? You may want to wait until you receive your next
statement to start using Budget, or you can use your latest statement balance at this point, and then enter
checks and deposits made after the date of your last statement when you finish the setup assistant.
You can create multiple accounts in Budget, For example, an additional checking account, a savings account,
or a credit card account. However, we suggest for now you just create one checking account to get started and
create additional accounts later after you are familiar with the program.
Also, before deciding to handle your credit card as an account in Budget, we suggest first reading Handling
Credit Cards to determine if you really want to do that or use one of the less detailed, simpler methods. If you
decide on the account method, see Adding Credit Cards for details on setting up the credit card account.
You can add, delete, or modify account information and options at any time in the program. See the Working
with Bank Accounts topic for more information.

Create Your Envelopes.
Envelopes are used to hold portions of the money in your account that you want to set aside for specific
expenses. You may want to create an envelope for each bill, such as "Rent" or "Phone", and also create
envelopes for discretionary expenses such as "Entertainment" or "Clothing". You can create as many
envelopes as you like.
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Select envelope names from the pull down menu or enter your own names. Click the CREATE button to enter
each envelope. If you've imported data from your Budget Workbook file, the names of your envelopes will
already be listed. When all of your envelopes are created, click the right arrow to go to the next step.
You can add, delete or modify envelopes at any time in the program. See the About Envelopes topic and the
Working with Envelopes topic for more details.

Distributing your current account balance to your envelopes.
The money that is currently in your checkbook is most likely needed to pay bills and expenses. You will now
set aside that money in the appropriate envelopes. Think of it as catching up with the fact that the balance that
is in your checking account would have been distributed to your envelopes if you had been using Budget all
along.
Example: If you need $1,000 to pay the mortgage in a couple of days, you might put $1,000 in the
"Mortgage" envelope. You could put $200 in the "Utilites" envelope and $300 in the "Grocery" envelope
for those expenses, and so on.
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Double click next to each envelope and enter the amount you want to place in that envelope. As you
distribute funds to the various envelopes, notice that the amount at the top changes to show the amount that
remains to be distributed. If you choose not to distribute all of your funds to your envelopes at this time, the
remainder will be placed in an envelope named "Available". Continue distributing your funds to each
envelope for each bank account. Once you are done, click the right arrow to go to the next step.

Budget Setup.

The next steps allow you to set up your budget so that future income can be automatically distributed to your
envelopes each time you get paid. Please read About Income to learn more and decide if you want to set up
your budget now or wait until later. If you decide to wait, you'll still be able to use Budget for standard
account management and expense tracking. Just click the FINISH NOW button and read the section, "You're
ready for normal use" at the end of this Getting Started topic. When you are ready to setup your budget just
follow steps 4 and 5 of the manual method of getting started.
If you want to continue and enter your income and expenses, click the right arrow.

Enter Income
Setting up your budget in advance and preallocating your future income to your envelopes is what gives
Budget it's full power to help you manage your budget. A budget consists of income and expenses, so the first
thing to do is to define the amount and frequency of your income (called "pay sources" in Budget).
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Change "My Pay" to whatever you want to call your pay source (for example, "Bob's Pay" or "Mary's Pay").
If you receive a pay check on a regular basis, enter the amount of the pay (or an average if it varies) and
select the appropriate fixed frequency. If you receive pay of different amounts at various times, enter an
average of each pay in the AMOUNT field, and select the variable pay frequency that best matches how often
you get paid each month. It is best to select the maximum number of pays you might receive in a month.
Then, if you defined more than one checking account, use the ACCOUNT pop up menu to tell Budget into
which bank account this pay is deposited. Click the CREATE button and the pay source will show up in the
table at the top. Repeat these steps if you have more than one pay source.
You can modify this information at any time, see the Set Up Your Income topic for more information.
Once you have all your pay sources defined, click the right arrow to go to the next step.

Enter Expenses
This is the "make your budget" step - you'll tell the program the amount and frequency of your expenses so
that it can calculate how much should be distributed to your envelopes each time you get paid.
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All your envelopes are listed down the left side of the screen. For each expense envelope, enter the expense
amount, and choose the appropriate frequency from the FREQUENCY popup menu. In the last column, select
the pay source you want to use for this envelope or select EQUALLY to share the expense among all pay
sources.
Most bills are due monthly, and have either a definite amount or you can compute an average amount.
Insurance and other types of bills are due annually or semi-annually, so select the appropriate frequency. For
discretionary expenses, you enter the target amount and frequency period that you desire.
Note: If you get paid "Weekly" or "BiWeekly", you may want to select that same frequency for ongoing
expenses, such as auto gas, groceries, lunch etc. Why? Budget does not normally take pay allocations from
the "extra" pays that occur every 3 months for "Weekly" or 6 months for "Bi-Weekly". EXCEPT when the
expense is also defined as either Weekly or Bi-Weekly. In the case of monthly expenses like rent or the
phone bill, the extra pay is really "extra" and not usually needed to pay the monthly expense. For ongoing
expenses, you usually need money allocated from each pay.
The table at the bottom shows your pay sources and the amount remaining per pay for each pay source. As
you enter your expense amounts and select which pay to use for each expense, the amount in the AMT. LEFT
PER PAY column will change to show how much you have left for other expenses.
Budget now has the information to calculate how much to allocate from each pay for your expenses.
Example: Your income is received 2 times a month, and you entered $1,000 as your monthly mortgage
expense. Budget will automatically calculate that $500 should be allocated from each pay to the
"Mortgage" envelope.
If you don't agree with Budget's default calculations - don't worry. You can add, delete, or modify your
expense amounts and pay sources, or modify the pay details at any time in the program. You can do this
using either the Pay Allocation Table to work on more than one Envelope, or the Envelope Info Window to
work on just one Envelope. The Envelope Info Window allows some advanced settings to fine-tune your
allocations.
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Remember - At this point you are only telling the program how much to distribute to the envelope When
You Get Paid. Your expense allocations will only get added to your envelopes when you record your pay.
On payday, your check gets deposited into the bank and you will record this in Budget by clicking on the
RECORD PAY toolbar button. Because you set up your allocations in advance, Budget is able to
automatically distribute your pay to your envelopes according to your allocations when you click RECORD
PAY NOW or you can make adjustments before recording the pay if your pay is variable or you want to make
changes to the pay you are distributing.
Once you have all your expenses defined, click the right arrow to go to the next step.

Set the features you would like to use.

Budget has an extensive feature set, and there are many preferences that you can set to fit the way you work.
Three of the most common options are shown in this step. Simply click the checkbox next to any of the
options to enable them. Click the right arrow to continue.
Once you have the features set, click the right arrow to go to the last step.

Finish
Once you click the FINISH button the setup assistant will take all the information you have entered and place
it in the Budget data file and display the main window. The main window will show all the accounts and
envelopes that you have created.
The transactions that you created in the setup process to distribute your current account balances are shown in
each envelope history window, account history window, and in the account's balance window.
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Warnings: The setup assistant may give a warning at the end if you have allocated more money to your
envelopes than you receive in each of your pays. This is allowed in Budget. But your Available envelope
will show the deficit as a negative amount. When you finish the setup assistant you can adjust your pay
allocations to avoid this.

You're ready for normal use
First, be sure to save your file and name it. See the saving your data file topic for more information.
The budget is now set up with your current account balance distributed into all of your envelopes. You can
now record a Check, Debit, orATM, or record a Deposit, etc. by FIRST selecting the appropriate envelope
and clicking the appropriate toolbar button to record the transaction.
If you are using Budget without setting up pay allocations, you can deposit your pay by using a Split Deposit,
and distribute it manually into your envelopes.
If you've set up your pay allocations in the "Enter Income" and "Enter Expenses" steps above, when your pay
day arrives simply click on the RECORD PAY toolbar button to Record Your Pay to distribute it in each
envelope as you defined when you created the envelopes or make adjustments before recording.
You can view your Transaction History (similar to a check register) of any envelope or all envelopes at any
time. You can click and drag to record a Transfer between envelopes. Best of all, you can easily Balance /
Reconcile your bank accounts when the bank statement comes each month.

Page 26 of 152

Setting up Manually
If you want to use the Setup Assistant to get started, see the Setup Assistant help section. When you cancel
the Setup Assistant, you see Budget's main window.

First: Create your bank accounts
A bank account is your real-world checking account that you have at your bank that you want to track and
manage with Budget.
The main window already has a default checking account named "Checkbook". To change the name of the
account, select the "Checkbook", and click the INFO button on the toolbar to get the ACCOUNT
INFORMATION window.
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Change "Checkbook" to your bank account name and enter the next check number that you want to start
tracking with Budget. Other account preferences can be set later after you finish getting started. Click DONE
and you will see your bank account name instead of "Checkbook" on the main window.
You can create multiple accounts in Budget, for example, an additional checking account, a savings account,
or a credit card account. However, we suggest for now you just create one checking account to get started and
create additional accounts later after you are familiar with the program.
Also, before deciding to handle your credit card as a bank account, we suggest first reading Handling Credit
Cards to determine if you really want to do that or use one of the less detailed, simpler methods. If you decide
on the account method, see Getting Started Using Credit Cards for details on setting up the account.
You can add, delete, or modify account information and options at any time. See the Working with Bank
Accounts topic for more details.
Second: Create your envelopes
Envelopes are used to hold portions of the money in your Account that you want to set aside for specific
expenses. You may want to create an envelope for each bill, such as "Rent" or "Phone", and also create
envelopes for discretionary expenses such as "Entertainment" or "Clothing". You can create as many
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envelopes as you like.
To create your envelopes, use the Envelope > New Envelope... menu command, an ENVELOPE INFO
window appears. Enter the ENVELOPE NAME, such as "Rent" or "Groceries". As this point, you can click on
the APPEARANCE tab if you wish to select a color or add an icon to the envelope - or just wait till later. For
now, we will simply enter the envelope name, and we will ignore the BUDGET, INFO, and OPTIONS
settings until a later step.

Close the window and you'll see your new envelope on the main window. Continue creating additional
envelopes for your budget expenses, and they will all be displayed on the main window.
You can add, delete or modify envelopes at any time. You can also group envelopes together (such as
creating a "Utilities" group to hold "Gas", "Electric" and "Water" envelopes). See the grouping envelopes
topic for more information.
Third: Deposit your Account Balance and distribute it to your envelopes
Now that you've named your checking account, and created envelopes, you will start your Budget file by
recording a deposit of your current account balance and distributing all or portions of the money to your
envelopes.
The money that is currently in your checkbook is most likely needed to pay bills and expenses. You will now
set aside that money in the appropriate envelopes. Think of it as catching up with the fact that the balance that
is in your checking account would have been distributed to your envelopes if you had been using Budget all
along.
To deposit your account balance, without selecting any envelopes, click the DEPOSIT button on the toolbar,
and the SPLIT DEPOSIT window will appear (see below). In the table in the middle of the window, you'll
first see an envelope named "Available" and then a list of the envelopes you created. (The "Available"
envelope is used to hold any money in your account that is not set aside for specific expenses in your other
envelopes).
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First fill in the top of the form with your starting balance information. In the amount column next to each
envelope, enter the amount of your account balance that you want to place in that envelope. The total amount
that you distribute to your envelopes (including the "Available" envelope) must equal your current account
balance. If you do not want to set aside all your money into your expense envelopes, just put the remainder
into the "Available" envelope.
Example: As shown in the image, your current checkbook balance is $3,500, and you will need $1,000 to
pay the mortgage in just a couple of days, so you put $1,000 in the mortgage envelope. You'll also need
money to pay the utility bill and to buy groceries. You put $200 in the Utilities envelope and $300 in the
Grocery envelope. After distributing your desired amounts to all of your envelopes, the note at the bottom
says you have an AMOUNT REMAINING TO BE DISTRIBUTED of $500. You decide to put that in the
"Available" envelope. The total amount of the deposit now equals $3,500, which is your current
checkbook balance. Click RECORD; when you are finished.
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Example (continued): Now you see that the main window shows your total checkbook balance of $3,500
which consists of $3,000 that has been set aside in expense envelopes plus $500 in the Available envelope.
You can modify amounts deposited to envelopes at any time by editing the transaction or transferring money
to other envelopes.
Note: In the next two steps, you will set up your income and expense information so that when you receive
income in the future, it will be automatically distributed to your envelopes. However, you can wait until
later to do this, and just start using Budget for standard account management and expense tracking. If you
decide to finish now, see "You're ready for normal use" at the end of Step 5 below.
Please read the About Income topic before completing the next two steps.
Fourth: Setup your Pay Sources
Setting up your budget in advance and preallocating your future pay to your envelopes is what gives Budget
it's full power to help you manage your budget. A budget consists of income and expenses, so the first thing
to do is to define the amount and frequency of your income (called "pay sources" in Budget).
Use the Accounts > Pay Source... menu command. Click the ADD button, and change "New Pay Source" to
whatever you want to call your pay source (for example, "Bob's Pay""John's Pay" or just "John" ).

If you receive a pay check on a regular basis, enter the amount of the pay (or an average if the amount varies)
and select the appropriate fixed frequency.
If you receive pay of different amounts at various times, enter an average of each pay in the AMOUNT field.
Now select the variable pay frequency that best matches how often you get paid each month. It is best to
select the maximum number of pays you might receive in a month.
If you have more than one bank account created in Budget, the last step is to select the bank account into
which this pay is deposited. For this example you only created a single bank account so it will be the only one
in the popup menu.
You can add as many pay sources as you wish. When you are finished, click DONE.
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You can add, delete or modify pay sources at any time.
Fifth: Create your Budget (Expenses)
This is the "make your budget" step - you'll define the amount and frequency of your expenses. Use the
Accounts > Pay Allocations... menu command. The PAY ALLOCATIONS window will appear. Click the
EXPENSE AMOUNT tab if it's not already selected, and you will see a list of your envelopes down the left
side.

For each expense envelope, enter your expense amount, and choose the appropriate frequency from the
FREQUENCY popup menu. Note that the MONTHLY column automatically computes a monthly amount for
you regardless of the frequency you actually set for the expense. Next enter the pay source from which you
want the funds allocated for this expense. For this example you only created a single bank account so it will
be the only one in the popup menu.
Most bills are due monthly, and have either a definite amount or you can compute an average amount.
Insurance and other types of bills are due annually or semi-annually, so select the appropriate frequency. For
discretionary expenses, you enter the target amount and frequency period that you desire. The bottom line is
to have enough money in each envelope when the bill is due to make the payment, and to budget enough
money for your discretionary expenses.
Note: If you get paid Weekly or BiWeekly, you may want to select "Weekly" or "BiWeekly" as the
frequency of ongoing expenses, such as auto gas, groceries, etc. The reason is that Budget does not
normally take pay allocations from the "extra" pays that occur every 3 months for "Weekly" or 6 months
for "Bi-Weekly", EXCEPT when the expense is also defined as either Weekly or Bi-Weekly. In the case of
monthly expenses like rent or the phone bill, the extra pay is really "extra" and not usually needed to pay
the monthly expense. For ongoing expenses, such as groceries, auto gas, lunch money, you usually need
money allocated from each pay.
Notice that as you enter expense amounts, the amount shown next to the "Available" envelope changes to
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show the amount of money each month from the pay source(s) that is not yet allocated for expenses - that
amount is available to allocate to expenses or to build up in the "Available" envelope.
After you set your expense frequencies, Budget computes the amount that should be deducted from each pay
source each time you get paid to meet your expense requirements. Click on the PAY DETAILS tab to see what
Budget has computed to be allocated to your expense envelopes each time you get paid.

Don't agree with what Budget calculated? It is simple to change any amount by double clicking on it and
entering a new amount.
Example: Your monthly mortgage is $1,000, and Budget allocated an even $500 out of each of your 2
pays per month. You may prefer to allocate $200 from your first pay and $800 from the second pay
because you have several other bills that need to be paid early in the month.
You can add, delete, or modify your expense amounts or modify the pay details at any time. You can do this
using either the Pay Allocation Table to work on more than one envelope (as we just did), or the Envelope
Info Window to work on a single envelope. The ENVELOPE INFO window allows some additional advanced
settings to fine-tune your allocations.
Close the PAY ALLOCATION window. Note that your envelopes still have just your current balance in them.
What happened to your expense allocations??? They only get added to your envelopes WHEN YOU GET
PAID, and you enter your pay using the RECORD PAY toolbar button (or menu command).
On payday, your check gets deposited into the bank and you will record this in Budget by clicking on the
Record Pay toolbar button. Because you set up your allocations in advance, Budget is able to automatically
distribute your pay to your envelopes according to your allocations when you click RECORD or you can
make adjustments before recording the pay.
Remember - At this point you are only telling the program how much to distribute to the envelope When
You Get Paid. Your expense allocations will only get added to your envelopes when you record your pay.
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On payday, your check gets deposited into the bank and you will record this in Budget by clicking on the
RECORD PAY toolbar button. Because you set up your allocations in advance, Budget is able to
automatically distribute your pay to your envelopes according to your allocations when you click RECORD
PAY NOW or you can make adjustments before recording the pay if your pay is variable or you want to make
changes to the pay you are distributing.
You're ready for normal use
First, be sure to save your file and name it. See the saving your data file topic for more information.
The budget is now set up with your current account balance distributed into all of your envelopes. You can
now record a Check, Debit, or ATM, or record a Deposit, etc. by FIRST selecting the appropriate envelope
and clicking the appropriate toolbar button to record the transaction.
If you are using Budget without setting up pay allocations, you can deposit your pay by using a Split Deposit,
and distribute it manually into your envelopes.
If you've set up your pay allocations in Steps 4 and 5 above, when your pay day arrives simply click on the
RECORD PAY toolbar button to record your pay to distribute it in each envelope as you defined when you
created the envelopes.
You can view your transaction history (similar to a check register) of any envelope or all envelopes at any
time. You can click and drag to record a transfer between envelopes. Best of all, you can easily balance /
reconcile your bank accounts when the bank statement comes each month.
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Adding Credit Card Accounts to Your Budget
Please read the Handling Credit Cards section first. That will help you decide if you want to use the
account method or one of the other methods described there.

Setting up the Credit Card Account:
The following instructions assume that you've already set up your working bank accounts (checking and
savings) and have created your expense envelopes.
First, set up the new account as a credit card account. (If you do not have a current balance on your credit
card, skip ahead to "After Setup" below).
Next, you'll need to initialize this credit card account with your current credit card balance by recording a
charge transaction to the credit card account.You may use either of these two methods to record the current
debt:
1. Record the existing debt as a lump sum.
If you don't want to enter the existing debt in specific expense envelopes, you can just record the charge as
one amount that represents all the charges you made in the past. You can put that amount in the credit card
account "Available" envelope; however, we suggest that you first create an envelope specifically for your
existing debt. You might want to name the envelope "Old Debt", or "Existing Debt", etc. You will then
record the charge in this envelope.
2. Record the existing debt in more than one envelope.
You can also distribute your debt to your envelopes. To do so, you will record a split charge. In the split
charge dialog, you would enter "Credit Card Starting Balance", and then enter the amount of the debt you
want for each envelope next to it in the table. The total amount at the top will be the total amount of the debt.
You will enter the numbers as positive, but Budget shows the amount you owe to a credit card as a negative
amount because it is money that you owe.
Any new charges you've made since that statement should be recorded as charges to your credit card account
in the appropriate envelope.
Note: To transfer debt between envelopes select the "To" envelope first and drag to the "From" envelope,
enter the amount and click RECORD. This seems backwards but it does indeed make the "To" envelope
more negative and the "From" envelope more positive.

After setup:
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To record a charge see the section on recording charges.
When your next credit card statement arrives, you should reconcile your credit card account. Use the balance
window to enter your statement balance and check off those transactions that show up on the statement.
(Remember to enter the statement balance as a negative number unless you overpaid your credit card
company and they owe you money). See the section on balancing your bank account for more information.
Handling refunds can be done in one of two ways. You can deposit the amount of the refund to the credit card
account using the appropriate envelope, or you can record a charge transaction and turn on the REFUND
checkbox. In either case, if you try to edit the refund transaction it will show up in the deposit window for
editing.

Paying the Credit Card Bill
After balancing a credit card account, you usually pay the credit card company from your bank account. In
Budget, we've streamlined the process a bit for you. Drag from the bank account that you're paying from and
drop on the credit card account you're paying off. You'll get a split check (or debit) transaction that has a
popup menu to help you fill in the amount of money you want to pay the credit card company. We suggest
you try to get to the point where you pay off your charges in full each month. The best way to deal with credit
card debt is not to have any. If you do pay off your credit card in full at the end of the month Budget has a
payment option that is perfect for that. It looks at those transactions you just reconciled in the BALANCE
window and sets up that amount.
To handle a large charge that you can't pay off at the end of the month we suggest you handle it just like
described above for handling existing debt. Create a new envelope with a name that reflects what the
purchase was, "New Furniture", for example. Balance the charge on the next statement and then pay it down
each month. Budget has two options when paying the credit card bill that help you do that. See the paying off
a credit card topic for more information.
Note: For paying off existing debt it is important to realize that you should not add any new charges to
these envelopes. Their specific purpose is to hold existing debt. To use the last two options when paying
the credit card bill these envelopes must have no current activity.
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Simplified Data Entry
There are many ways to do things in the Budget application. There is a menu bar which contains all of the
commands in Budget. There is a toolbar which you can configure for commonly used commands. There are
also keyboard short cuts (hold the Command key while typing a letter). There are also single mouse clicks,
double mouse clicks, and Command key mouse clicks. You may want to experiment with different methods
to find the one that is easiest for you.
Example: You can select an envelope by clicking in the envelope box once, select a second envelope by
holding the shift key and clicking in the second envelope box. Then use the Transactions > Transfer...
menu command to transfer money from the first envelope to the second. Or you can simply use drag and
drop to drag from one envelope to another to do a transfer of funds.
When entering a transaction, the fields are automatically filled in with the information from the previous
transaction written in that envelope. This provides a very simple means of writing recurring checks (for
example, the mortgage check normally doesn't change).
When creating new items such as Pay Sources or Envelopes a sample is created for you that you can then
modify.
Example: When you activate the NEW ENVELOPE command, an envelope named "New Envelope" is
automatically created. At this point you can then change the name from "New Envelope" to the whatever
you want, for example "Mortgage" or "Grocery".

Amount Fields
The program provides for simplified entry. Amounts can be entered with no need to enter the currency
symbol or thousands separator. You must use the decimal symbol to indicate portions of the currency.
Example: An entry of 1000 is the same as entering $1,000.00. An entry of 123.4 is the same as entering
$123.40.
The currency symbol, thousands separator, and decimal place indicator can be changed to whatever you
prefer. See the General Preferences help for a description of how to change your currency format.

Date Fields
The program also provides a simple manner for date entry. Defaults are always used where appropriate.
Example: If your date format is mm/dd/yy, entering "9/6" would be September 6th of the current year.
Entering just "6" would be the 6th day of the current month and year.
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You can use the + and - keys to increment or decrement the date by one day. With the Option/Alt key held
down, the + and - keys increment or decrement the date by one month. You can press the T key to set the date
to today.
You can change the order of the month, day, and year and also the separator symbol using the System
Preferences application. See the General Preferences topic for a description of how to change your date
format.

Page 38 of 152

About Transactions
Budget transactions can be created for a single envelope or for multiple envelopes. Single envelope
transactions (standard transactions) only effect the envelope selected. When created, the transaction is placed
in the envelope's history which can be viewed at any time. Multiple envelope transactions (split transactions)
effect all the envelopes selected, or if no envelopes are selected, all of the envelopes in your budget file.
When created, the transaction is placed in the history for all the envelopes which had a non-zero amount for
that envelope, and the transaction is also entered into the bank account's history showing the total transaction
amount.

Entering information in standard transactions.
Selecting a single envelope and then clicking on a transaction icon in the toolbar or using a Transactions
menu command will display a standard transaction window. The window will show the bank account box in
the upper left, the envelope box for the envelope selected in the upper right, and a number of fields to enter
information. The exact number of fields is dependent on the type of transaction being created. You can
change the bank account by using the popup menu from the bank account graphic. You can also change the
envelope selected by using the popup menu from the envelope graphic.
When Budget displays a standard transaction window, normally the first field will be selected and have the
cursor set. You can enter information into the field by typing on the keyboard. When you have the
information for that field entered, you can either tab to the next field of click the next field with the mouse to
select it and then enter the information.
Once you have all the information entered into the fields you can then click the RECORD button to actually
create the transaction. Click RECORD & REPEAT instead if you want to repeat the same type of transaction
in the same envelope. You can also click the RECORD & REPEAT to repeat the same type of transaction in a
different envelope or a different account by using the popup menu from the envelope or bank account
graphic. A record of this transaction will be placed in the selected envelope's history. You can display an
envelopes history by using the HISTORY icon in the toolbar, or the Envelope > Envelope History... menu
command.

Entering information in split transactions.
Selecting more than one envelope or no envelopes and then clicking on a transaction icon in the toolbar or
using a TRANSACTIONS menu command will display a split transaction window. There are two parts to a
split transaction window. The top part looks the same as a standard transaction window without the envelope
box in the upper right along with a number of fields to enter information. The exact number of fields is
dependent on the type of transaction being created. You can change the account by using the popup menu
from the bank account graphic.
The bottom part consists of a table with a number of columns. The first column is a list of the envelopes
selected or all of your envelopes if no envelopes were selected. If you selected a number of envelopes there
will be a checkbox to toggle between all of your envelopes and the ones you selected. The other columns are
for entering amounts for each envelope along with additional information.

Page 39 of 152

To enter amounts (or any information) in the table select the row that contains the envelope for which you
want to enter an amount and then double click the amount next to that envelope.

Working with amounts in split transactions.
The split Transfer transaction main amount field is disabled. You must enter amounts in the table. As you
enter amounts in the table the total amount of the transaction is placed in the main amount field.
The split deposit, debit, check, charge, and credit card payment transactions have an additional field
AMOUNT REMAINING TO BE DISTRIBUTED. You can enter amounts for these transactions in either of
two ways.
1. You can enter a total amount in the main AMOUNT field and the AMOUNT REMAINING TO BE
DISTRIBUTED field will show the same amount. As you enter amounts in the table the AMOUNT
REMAINING TO BE DISTRIBUTED will change to show you the amount that you still have to enter
into the table.
2. You can enter an amount into the table and as you enter each amount the main AMOUNT field will
show you the total entered so far.
The AMOUNT REMAINING TO BE DISTRIBUTED field must be equal to $0.00 before the RECORD button
will be enabled.
Once you have all the information entered into the table you can then click the RECORD button to actually
create the transaction. A record of this transaction will be placed in each envelopes history showing the
amount distributed to that envelope along with it's information entered in the table. A record of the
transaction will also be placed in the bank accounts history showing the total amount of the transaction and
the information from the top part of the window.
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Shortcuts
To execute keyboard shortcuts hold down the Command key and press the corresponding letter/function key.
Check
spelling
B
- Balance
Launch
U
- account
URL
Pay
Shift+I - Source
Info
New
group
G
- with
selected
envelopes
Envelope
L
history
Record a
K
check
Record a
E
debit
Record a
D
deposit
Record a
T
transfer
Repeat
R
- last
transaction
Edit
Shift+E - selected
transaction
Void
Backspace transaction
Record a
Y
pay
Minimize
M
- front
window
?
- Help
;

,

- Preferences
New budget
N document
Open budget
O document
Close front
W window
Save budget
S document
Save budget
Shift
- document as
+S
new file
Shift
- Page setup
+P
Print focused
P view
Z - Undo
Shift
- Redo
+Z
X - Cut text
C - Copy text
V - Paste text
A - Select all
Show Info for
I selected item
Find
F transaction

-

Page 41 of 152

●

●

Note 1: When working with more than one account holding the mouse over a group envelope on
the main window will show it's envelopes and their balances.
Note 2: When working with more than one account holding the mouse over the envelope box in
transaction windows will show the envelope's balance in all accounts.

There are also mouse action short cuts. Hold the following keys while clicking the mouse.
Clicks on envelope graphics can access program functions.
Single click -

Select

Shift single click -

Multiple Select (Total)

Double click -

Record check/debit -orOpen group envelope window -orUpdate Price Per Share (PPS)

Option double click -

Record deposit -orOpen group envelope -orBuy shares

Right-click or Control-click - Display context menu with common commands
Command double click -

Open envelope history window

Click and drag -

Transfer funds

Clicks in a bank account box can access program functions.
Single click -

Select

Double click -

Display Balance window

Option double click -

Record split deposit

Right-click or Control-click - Display context menu with common commands
Command double click -

Display History window

Clicks in a History window list can access program functions.
Single click -

Select transaction

Double click - Show Transaction Information window
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Working With Bank Accounts
All Budget documents start with a default bank account named "Checkbook". You can create additional bank
accounts as needed. Bank accounts in Budget are the equivalent of your real world bank accounts. They may
be either checking, savings, or credit card accounts.
Note: When you create a new account all your existing envelopes will show in the new account. If you
create additional envelopes they will appear in all your accounts.

Setting up A Bank Account
Setting up a new bank account or modifying an existing bank account can be done at any time. To setup a
new bank account, use the Accounts > New Account... menu command. The bank account is created with
the name "Bank Account n" where "n" is the number of the bank account. The bank account info window is
displayed so you can set specific options for the new account.
See the bank account getting started topic to enter a starting balance in a bank account or see the credit
card account getting started topic to enter a starting balance in a credit account. Don't know what your
current bank balance is? Use the method describe at the bottom of this page for how to determine your
bank balance.

Setting or Changing Bank Account Options
To modify an existing bank account, first select it, then click the INFO toolbar button or use the Accounts >
Account Info... menu command.
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You can change the name of the account to anything you like. Bank account names can be any length but you
should limit them to about 16 characters to prevent any truncation in the display windows.
Select if this account is either a standard bank account (checking or savings) or a credit card type account.
Note: First read the handling credit cards topic to determine if you want to handle your credit card as an
account or use one of the simpler methods. You should also read the getting started with credit cards topic
for more information.
For standard bank accounts, enter the number of the next check in your checkbook.
Check the ALLOW BANK ACCOUNT TO GO NEGATIVE checkbox if you want Budget to allow negative
values in the account. If you do select this option WARN WHEN BANK ACCOUNT GOES NEGATIVE will
be automatically selected, although you can turn off the warning if you prefer.
Note: It is not wise to select these options except in special circumstances, since Budget bank accounts
reflect your real world bank accounts. You should never let your real world bank accounts go negative
either.
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Selecting the DEBIT IS DEFAULT ACTION will cause a double click on an envelope to start a debit
transaction instead of the standard check transaction.
Checking the checkbox SUPPRESS AUTOMATIC AVAILABLE TRANSFER cause Budget not to ask if you
want to transfer funds from the available account if you attempt to write a check from an envelope that does
not have enough funds to cover the check. That is, the envelope will go negative.
The table at the bottom is used for associating envelopes with accounts. By default all envelopes are
associated with all accounts. Check the header of the checkboxes to toggle all envelopes to be associated with
an account or not. Check the box next to each envelope to associate that envelope with an account. For more
information see the Associated Envelopes section.
Click the SIGNATURE tab to add your signature to Budget for printing on your checks.

To place an image of your signature on your checks, click the SIGNATURE tab. You can drag an image file
to the signature image well or use the BROWSE button to show the standard navigation window to find your
image file. The signature image and next check number can also be entered in the Check Print Setup process.
Checking the checkbox PRINT CURRENCY SYMBOL ON CHECK prints whatever currency symbol you
have set with the amount.
Click the INFO tab to change general information about the account.
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You can enter a URL for accessing your bank's web site. Entering a URL enables the Accounts > Launch
Account URL menu command whenever the bank account is selected. The Accounts > Launch Account
URL command will bring up your default web browser and access the site specified. This is handy if you
want to check your bank balances or access your bank data as a QIF file.
You can also enter any textual information in the NOTE field such as the address of your bank.
Click the APPEARANCE tab to change how the account is displayed.
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You may set a color tint for the account. Click the SET SPECIFIC COLOR checkbox if you want this option,
and then click the color box to select a color.
Accounts may display a small icon in the bottom left corner of the account. To set an icon to display with an
account, expand an icon pack in the table by clicking on the indicator on the left then select the icon in the
list. To remove it click the NONE button. See the Preferences topic for more details on icon packs.
Click the DONE button when you have finished reviewing and/or changing information.

How to determine your bank balance
If you don't know your current bank account balance you can use the following method based on your bank
statement. First get your most recent bank statement. If you don't have one we suggest you wait to start using
Budget until you receive it from the bank. Then, enter the statement balance as a deposit to the account. (If
you created envelopes already, a split deposit will allow you to distribute the deposit to your envelopes, or
put it all in the Available envelope.) Next, enter every transaction that you have made to that account since
the statement date into Budget. The amount shown in the total box will be your current account balance.
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Handling Multiple Bank Accounts
When you setup a second bank account (Checkbook, Savings, or Credit Card) in Budget, the main window
changes from the standard display. The main window will show your bank accounts in a scrollable list down
the left side of the window with your envelopes to the right.

Note: See the "Envelopes with multiple bank accounts" section of the Envelopes in Budget topic for more
information about how envelopes and bank accounts interact.

Recording Transactions
When creating transactions in Budget (check, deposit, etc.) each transaction window displays the bank
account in the box at the top left. To change the bank account, click the small down arrow and use the pop up
menu to select a bank account. You must have sufficient funds in a particular bank account to cover the
amount of any withdrawal.
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Example: You have $500 in your "Mortgage" envelope from the First National Bank and $500 in your
"Mortgage" envelope from your spouse's Crestar Bank; you can't write a check for $1000 to pay the
mortgage. The reason is simple to understand if you think in real world terms. That is, from which bank
would you really write the check?
Default information for new transactions are determined by the following rules. With no bank account
selected on the main window, the last transaction's information for that transaction type would be used. If a
bank account is selected on the main window, then the last transaction's information for that bank account
and transaction type is used.
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Moving Bank Accounts
Bank account positions may be moved on the main window. To move an account hold the Command key and
drag an account between two other accounts to reposition it. When the edges of the other accounts hilite,
release the mouse to drop the account in that position.
You can also move an account to the last position by dropping it on the bottom half of the current last account.
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Associated Envelopes
Associate envelopes allow you to set which envelopes are part of an account. A "Rent" envelope may make
sense in a "Checking" account but not in a "Savings account" likewise a "Travel Savings" envelope may
make sense in a "401K" account but not in a "Checking account" When an envelope is associated with an
account it will show on the main window when that account is selected, in the "Total" account, or in any of
the other windows when working with that account. If an envelope is not assoicated with an account then for
all pratical purposes it does not exist in that account.
Normally all envelopes exists in all accounts. When you create a new envelope it is automatically associated
with all accounts. However, you can tailor which envelopes are associated with an account by showing the
account's Information window. To do so, select the Account and click the INFO toolbar button or use the
Accounts > Account Info... menu command. Click the Settings tab and in the table set the checkbox next to
each envelope you want associated with that account. Clicking in the header of the checkbox column
associates all envelopes with the account.
Warning: You will receive a warning if you try to unassoiate an envelope with an account that either has
a current balance or has allocations being made from a pay source.

See the section Envelope Views to configure the way envelopes are shown on the main window.
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Balancing Your Bank Accounts
Balancing a bank account (Checking, Savings, or Credit Card) is a simple process in Budget. To access the
Balance window, first select the account and then use the Accounts > Balance... menu command. The
Balance window has the account total in the upper left corner and the statement date and balance field in the
upper right. The list of items on the right side are the deposits, and the list of items on the left side are
withdrawals (checks, debits, ATM, etc.). Payments and charges will be listed if you are balancing a credit
card account.
In the top center of the Balance window is the balance indicator and amount. When your budget and the bank
agree the balance indicator will be level and the amount will show $0.00. If the indicator is not level then the
amount shown is the difference between your Budget bank account and the real bank. The indicator must be
level before you can balance your bank account. (See also the section on Force Balance below).
Clicking the column header IDENT in the check list sorts the list by the check number. Clicking the column
header DATE in either list sorts the list by date. Double clicking an item in the balance lists will display
complete information about the transaction in the Transaction Information window.

How To Balance A Bank Account
We use a checking account for this example, but the process is the same for a credit card account.
If you have more than one bank account defined, select the account you want to balance. See the Multiple
Bank Accounts topic for more information.
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1. Enter the statement balance and date as shown on your bank statement in the fields in the upper right.
Note: The statement balance for a credit card should be entered as a negative number if you owe
money to the credit card company.
2. Click on the checkbox for each deposit and withdrawal that the bank has received in the lists. This
indicates that the item has cleared the bank. The totals for all items checked will be displayed at the
bottom of each list. As you click each item the balance indicator icon and amount at the top center will
change. When your account is balanced the indicator will be level with a balance amount of zero. If
this is not the case, recheck each item. Insure that each item agrees with the bank statement. Also
insure that each item on the bank statement is shown in the list and checked.
3. Once all the items are accounted for, click the BALANCE button. This will remove all checked items
from the lists and place a balance icon next to each transaction in their corresponding envelope history
windows. This reconciles your bank account and returns you to the main window.
Note: If the balance icon is tilted down on the left side (towards the bank account image), that usually
means that you think you have more money in your account than the bank does. Look for checks or debits
in your bank statement that have not been entered into Budget.
If the balance icon is tilted down on the right side (towards the STATEMENT BALANCE field), it usually
means that you think you have less money in your account than the bank does. Look for deposits in your
bank statement that have not been entered into Budget.

Force Balance
Can't get the bank account to balance correctly? You can force your bank account to agree with the bank.
Proceed as you normally would for balancing your bank account. Enter and check all the known items on
your bank statement then enter the bank's balance into the STATEMENT BALANCE field. When you have all
the known items checked off use the Accounts > Force Balance menu command. A transaction with the
amount shown under the balance icon will either be added to, or subtracted from, the "Available" envelope.
Your bank account will be balanced.
Warning: When you record a force balance, you are agreeing with the bank that their statement records
are correct.
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Envelopes in Budget
Envelopes are used to hold portions of your money that you want to set aside for specific expenses. You can
create as many envelopes as you like. You may want to create an envelope for each "bill", such as "Rent" or
"Phone", and also create envelopes for discretionary expenses such as "Entertainment or "Clothing".
The money that you set aside in envelopes is still shown in the bank account total - its just earmarked or set
aside in envelopes so you know what its for before you spend it. You don't have to set aside ALL the money
in your account; Budget has a built in envelope called "Available" that you can use. When we say all money
in the bank account must be in an envelope - that includes the "Available" envelope. So if you want to deposit
money and you don't want to put it in any expense envelope, put it in the "Available" envelope.
Note: When you look at Budget's main window, the sum of the amounts in your expense envelopes plus
the amount in the "Available" envelope equals the total amount in the bank account.
In Budget you can set up your budget in advance and preallocate future income into your envelopes each time
you get paid. You can set up your budget by using the Pay Allocation Table if you are working on more than
one envelope, or the envelope info window to work on just one envelope.
Also, you can personalize your envelopes with colors and icons, add notes and URL links, group envelopes,
move envelopes into a different order on the main window, and transfer money between envelopes.
Normally all envelopes exist in all accounts. However, you can tailor which envelopes are in which account.
For more information see the Associated Envelopes section.

Envelopes with multiple bank accounts
If you set up more than one bank account in Budget, the same envelopes will be used to hold money from all
accounts. For example, you may have a "Travel" envelope in which you've set aside $500.00 from your
Checking account and $2,000.00 from your Savings account. As shown below, when you select the checking
account (image A) the "Travel" envelope shows $500.00, when you select the savings account (image B) the
"Travel" envelope shows $2,000.00, and when you deselect all accounts by clicking in the Total box (image
C) the "Travel" envelopes show $2,500.00 which is the total (net) for all accounts.

A.

B.

C.

When you spend money you will record the check or charge transaction from the appropriate account and
envelope, and when you deposit money you record the deposit or pay transaction into the appropriate account
and envelope. The main window will reflect the change in both the total bank account balance and your
envelope balances.
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Working With Envelopes
Create An Envelope
Creating a new envelope or modifying an existing envelope can be done at any time. To create a new
envelope use the Envelopes > New Envelope menu command. The creation of an envelope is determined by
the front window. If the main window is in front, a new budget envelope will be created there. If a group
window is in the front the new budget envelope is created in the group. If the investment window is in front, a
new investment envelope will be created. In all cases the envelope is created with the name "New Envelope",
and the envelope info window is displayed.
To modify an existing envelope, first select it, then click the INFO toolbar button or use the Envelopes >
Envelope Info menu command.
Use the ENVELOPE NAME text field to change the name of the envelope. Envelope names can be any length
but you should limit them to about 16 characters to prevent any truncation in the displays.

Setting or Changing Envelope Appearance
Click the APPEARANCE tab to change how the envelope is displayed.

SET SPECIFIC COLOR - Set this option if you want to have this envelope display in a different color from
the default envelope color. Click the color well to select the color to display. See the Preferences topic for
more details on setting the default envelope colors.
Envelopes may display a small icon in the bottom left corner of the envelope. To set an icon to display with
an envelope, expand an icon pack in the table by clicking on the triangle on the left then select the icon in the
list. To remove it click the NONE button. See the section Preferences for more details on icon packs.

Setting or Changing Envelope Info
Click the INFO tab.
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You can create a note for each envelope. The note may be any information you want to associate with this
envelope.
You can enter a URL for accessing a web site. Entering a URL enables the ENVELOPE's context menu (hold
the control key and click the envelope on the main window) LAUNCH ENVELOPE URL command. The
Envelopes > Launch Envelope URL command will bring up your default web browser and access the site
specified.

Setting or Changing Expenses and Pay Allocations
Click the BUDGET tab.

Set the amount you want to budget for this envelope into the EXPENSE AMOUNT field.
Set the frequency of the expense in the popup menu. Basically this is how often you need the amount
specified above.
Set which pay source to use when paying the bill. Check the box next to each one you want to use. Use the
selector if want either an equal amount or a proportional amount allocated from each pay.
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Set a limit for the amount of money the pay can distribute to this envelope. A zero amount means no limit.
Once you have set this information Budget will determine the amount needed and automatically compute
your pay allocations. The total amount allocated to your envelope will be shown in the ACTUAL AMOUNT
ALLOCATED section and you can use the popup to display the amount for any time period.
To see the amount for each pay that Budget has computed click the PAY DETAILS button to show the PAY
DETAILS drawer.

Each pay for all of your defined pay sources will show in the PAY DETAILS table. You can change any
amount in the pay details table by double clicking it and entering the amount. The ACTUAL AMOUNT
ALLOCATED section will be updated to reflect the change. The UNALLOCATED column shows you how
much is left in your pay that has not been assigned to an envelope. This is the same amount that will be
placed in the "Available" envelope when you use the Record Pay command.
Note: Changing amounts in the PAY DETAILS will not change the EXPENSE
AMOUNT.
You can also set an allocated amount as a percent of your total pay amount. To do so use the bottom table in
the PAY DETAILS drawer and set the percent next to the pay source. When a pay has a percentage set it is not
computed with the expense amount. The percentage amount will be recomputed each time you change the
amount of the pay source.
Note: You can also work with multiple envelopes in a table format, see the Pay Allocation Table topic for
more information.

Setting or Changing Envelope Options
Click the OPTIONS tab to set one of three options for this envelope.
●

●

MONEY TRANSFERRED IN... - Set this option if you want transfers to this envelope to be used in
statistics.
MONEY TRANSFERRED OUT... - Set this option if you want transfers from this envelope to be used
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●

in statistics.
SHOW GRAPH... - Set this option to show the ratio of the envelope balance to the expense amount as
a small graph on the envelope.
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Group Envelopes
Similar envelopes may be grouped together. Envelopes like "Phone", "Electric", "Cable", etc. could be
grouped together in a group called "Utilities". Budget provides statistics on each envelope but can also
provide statistics on groups. Group envelopes allows you to better understand how your funds are distributed
and how well you are doing with your budget.
If you hover the mouse pointer over a group envelope on the main window, a tooltip will appear displaying
the names and balances (modified for the selected bank account) of envelopes contained in the group.
The simplest way to group envelopes is to select each envelope that you want to be part of a group. With all
the relevant envelopes selected, use the Envelopes > New Group With Envelopes menu command. Budget
will display the group info window. This window is similar to the normal envelope info window. The group
will be given the default name of "New Group". You can enter a note for the group if you wish, as well as
change it's appearance.

Example: Continuing the example above you would select the "Phone" envelope by clicking it once, then
hold the shift key down while clicking on the "Electric" envelope, and then while still holding the shift key
down click on the "Cable" envelope. With all three envelopes selected use the Envelopes > New Group
With Envelopes menu command. Budget will display the "New Group" group info window. You would
then change it's name to be "Utilities".
You can ungroup envelopes by selecting the group and then using the Envelopes > Ungroup menu command.
You can also use drag and drop with the Command key held down to move envelopes in and out of groups or
to any position on the window. If you drag an existing envelope into another existing envelope a new group
will be created with both envelopes. If you drag the next to last envelope out of a group then the group will
disappear and the last envelope will be ungrouped.
When using drag and drop to transfer money between envelopes, or to move envelopes, hovering the drag
over a group envelope will result in the group window springing open so you can finish the drop on a specific
envelope within the group.
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Restrictions:
●
●

You can not group the "Available" envelope.
You can not create a group within a group.

Group envelopes may display a small icon in the bottom left corner of the envelope. To set an icon to display
with an envelope click the APPEARANCE tab. Expand an icon pack in the table by clicking on the triangle on
the left then select the icon in the list. To remove it click the NONE button. See the section Preferences for
more details on icon packs.

SET SPECIFIC COLOR - Set this option if you want to have this envelope display in a different color from
the default envelope color. Click the color well to select the color to display.
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Moving Envelopes
Envelope positions may be moved on the main or group windows. To move an envelope hold the Command
key and drag an envelope between two other envelopes to reposition it. When the edges of the other
envelopes highlight, release the mouse to drop the envelope in that position. You can also move an envelope
to the last position.
You can create a new group by dropping an envelope directly onto another envelope on the main window.
When using drag and drop to move envelopes, hovering the drag over a group envelope will result in the
group window springing open so you can finish the drop within the group.
Note: 1 The "All Envelopes" View must be selected before you start the drag operation. Note: 2 If there is
more than one account you must click in the Total box first to deselect all accounts before you start the
drag operation.
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Deleting Envelopes
Envelopes may be deleted from a document. When envelopes are deleted, their history records are saved to a
text file (budget envelopes only, not investment envelopes) . See the Archive Data Format topic for more
information. Any funds left in the envelope will be transferred to the "Available" envelope. To delete an
envelope, first select it, then use the Envelopes > Delete menu command. You will be asked to confirm the
action with the warning window shown below; click the YES button if you are sure you want to delete the
envelope.
Note: You can not delete an envelope that has unbalanced transactions. If the envelope has unbalanced
transactions you will have to wait until the transaction has cleared the bank, and you have checked it in the
balance window and balanced your budget. Alternately, you may void and then delete the unbalanced
transactions.

You will then see the standard save window. Use this window to select where to save the archived data. Save
the file by clicking on the SAVE button. If you cancel the save, the archive records will not be written;
however, the envelope will still be deleted.
Warning: The delete command can not be undone. However, it is possible to restore the envelope if you
close the document WITHOUT saving, then open the original document again.
When the envelope is deleted, any funds in the envelope will automatically be transferred to the "Available"
envelope.
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Envelope Views

Envelope views allow you to tailor the way envelopes are displayed on the main window. An "All
Envelopes" view is automaticaly created by Budget an can not be modified. You may create as many
additional views as needed. To create an additional view select an existing view and then click the "Plus" (+)
button on the main window. A new view is created with the same settings as the original view you selected.
To modify the view click the "Settings" button. In table on the left of the drawer check the envelopes you
want to see in that view.
Envelope views a helpful in showing envelope in different configurations. For examlple your main view may
have group envelopes. You can create and configure an "Expanded View" where all your group envelopes
show as individual envelopes on the main window. Another use would be to hide envelope you no longer use.
Note:All envelopes are shown in the settings table even if they are unassociated with the currently selected
account. In that case you will not be able to configure the envelope.

See the section Associated Envelopes to configure which envelopes are part of an account.
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Handling Income in Budget
Each time you deposit your income into Budget, you will distribute it to your envelopes to refill them. There
are two ways to do this:
1. You can record a split deposit to your checking account. In the split deposit window you can manually
distribute the deposit to your envelopes.
2. You can use the Record Pay Command and Budget will automatically enter the deposit and distribute
your pay to your envelopes.
Here is an example of the main difference between the two methods. Suppose you have created 3 envelopes
and you get paid $300 every week. This week you deposit your pay at the bank, and in Budget you would
record the deposit of $300 to your checking account, then distribute $100 to each of your 3 envelopes. Next
week you would again deposit your pay at the bank and again in Budget you would record the deposit, and
distribute $100 to each of your 3 envelopes. You would repeat this step each time you get paid. Now wouldn't
it be a lot easier to somehow say "each time I get paid put $100 in each of these 3 envelopes"? This is exactly
what an "Record Pay" command does in Budget.
You can use the split deposit to enter your income at any time, however, to use the Record Pay command,
you will first have to decide if you want to create your allocation plan manually or let Budget do it for you.

Do it your self
You may want to develop your own pay allocation plan and not use Budget's calculations at all. To be able to
do this, DO NOT define "Expense/Budget" amounts. (Just skip that step in the setup process). Without
"expense" information, Budget will not calculate your pay allocation amounts. You will then be able to
decide how you want each pay allocated and Budget will simply use your numbers.
Using the "Pay Allocations" window (from the Accounts menu), click on the Pay Details Tab. You'll see a
list of your Envelopes with no pay allocations. Enter amounts directly to set the individual amounts that you
want allocated from each pay to go into these envelopes.
Using the "Envelope Info" window for an individual envelope, click on the "Pay Details" button. (Do not
enter anything in the "Expense Amount budgeted" field). You can enter amounts directly into the Pay Details
table to set amounts allocated to that envelope from each pay.
After you've set up your pay allocation plan, you'll be able to use the "Record Pay" command each time you
get paid. You can review your pay allocations and make adjustments before recording the pay if you wish, or
just record the pay without adjustments.

Let Budget do it automatically
Define your Expense (Budget) Amounts to set the total amount needed for the expense and which pay source
it comes from. Budget does the calculation to evenly take money from each pay to meet the expense
requirements. This means that if you get paid twice a month and have a monthly expense of $1,000, Budget
will allocate $500 out of each pay for that expense.
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You may define your Expense (Budget) amounts and frequency in several different ways:
1. During the Setup Process (Step 5 in "Set up Manually"; and the "Enter Expense" step in the Set up
Assistant).
2. Using the "Pay Allocations" window (from the Accounts menu), Expense Amounts tab.
3. Using the "Envelope Info" window for an individual envelope. Use the "Expense Amount (Budgeted)"
field to specify the amount and frequency required, and also to select which pay source(s) to use.
Modify Budget's Calculations
You may not agree with Budget's default calculation for some expenses; e.g., you may want to pay some bills
totally from your first pay of the month, and other bills total from your 2nd pay of the month rather than
allocating an even amount from each pay. If you want Budget to do the math and just want to make a few
modifications to Budget's calculations, you may do that in two ways:
1. Using the "Pay Allocations" window (from the Accounts menu), click on the Pay Details Tab. You'll
see a list of your Envelopes and Budgets calculated pay allocations. Change any of the amounts.
2. Using the "Envelope Info" window for an individual envelope, click on the "Pay Details" button to see
how Budget has calculated the pay allocations. Change any of the amounts.
Once you have your allocation plan define your pay sources ("Amount and Frequency"), and define your
expenses ("Amount and Frequency") so Budget can calculate how much to distribute to your envelopes each
time you get paid. You do this only once. Then each time you get paid you tell Budget to enter the pay and it
automatically distributes the pay for you.
Note: You can make adjustments to the amounts before distributing a "fixed" pay if you wish, or in the
case of a "variable" pay, you will have to make adjustments to enter the exact amount of the pay. This is
done with a split deposit window that will show your envelopes and their allocated amounts, which you
can easily change.
Defining Your Pay Sources
When you set up your pay sources, either by using the Setup Assistant or in the pay source window, there are
two parts, the amount and how often you get paid. Budget has a predefined list of pay frequencies that you
may select.
If you are paid on a regular "fixed" basis, just enter the amount and one of the first 4 frequencies shown
below. However, if you receive variable pay of different amounts and/or different frequencies, you would
enter an average pay amount, and select the "variable" frequency that best matches how often you get paid
each month. It is best to select the maximum number or pays you might receive in a month. For a more
advanced method of handling Variable Pays, see "Rules Based Allocations" below.
Pay frequency definitions:
●
●

Monthly - 1 pay each month (12 per year)
Semi Monthly - 2 pays per month (24 per year)
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●
●
●
●
●
●
●

Bi-Weekly - 2.17 pays per month (26 per year)
Weekly - 4.34 pays per month (52 per year)
Variable1 - about 1 pay per month (about 12 per year)
Variable2 - about 2 pays per month (about 24 per year)
Variable3 - about 3 pays per month (about 36 per year)
Variable4 - about 4 pays per month (about 48 per year)
Variable5 - about 5 pays per month (about 60 per year)

Defining Your Expenses
Once you have defined your pay sources, the next step is to define your expenses. You can define your
expenses during the Setup Assistant, by using the Pay Allocation Table to work with all you envelopes, or in
each individuual envelope. With that information, Budget automatically calculates your "pay allocations" (the
amount of money to distribute to each envelope each time you get paid). Budget has a predefined list of
expense frequencies that you may select.
Expense frequency definitions:
●
●
●
●
●
●
●

Annually - 1 payment each year
Semi-Annually - 2 payments each year
Quarterly - 4 payments each year
Monthly - 1 payment each month (12 per year)
Semi Monthly - 2 payments per month (24 per year)
Bi-Weekly - 2.17 payments per month (26 per year)
Weekly - 4.34 payments per month (52 per year)

For each expense, Budget determines the amount needed each month and divides it by the number of pays in
the month, except for the following rule:
When a pay is defined as either Weekly or Bi-Weekly, Budget does not take allocations from the "extra" pays
that occur every 3 months for Weekly or 6 months for Bi-Weekly, EXCEPT when the expense is also defined
as either Weekly or Bi-Weekly.
Why? In the case of monthly expenses like rent or the phone bill, the extra pay is really "extra" and not
usually needed to pay the monthly expense. The extra pay can be used to pay bills that occur semi-annual or
annually or placed in savings. However, for ongoing expenses that occur weekly or biweekly like groceries,
automobile gas, lunch money, etc. a portion of each pay is needed each time for these expenses.
If you want to change the calculations that Budget has made, you can easily do so either in the Pay Allocation
Table or in the individual Envelope Info window.
You do not have to define pay sources or expenses and set up pay allocations to use Budget. If you don't do
this, you can still create envelopes and set aside money for expenses. Budget will work just like any other
checkbook manager allowing you to write checks, make deposits, balance your checkbook etc. However,
defining pay sources and preallocating pay to your envelopes are what gives Budget it's full power to help
you manage a budget.
Rules Based Allocations
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Budget has a more advanced method of handling pays that are variable. You can set up rules that specify how
your pay is to be distributed. Rules are best used when your pay varies greatly from one pay to another or
when you want to allocate your money to your envelopes on a "priority" basis. See the section Pay Rules for
more information. For pays that vary a small amount you can define your pay as a "variable" pay and use the
standard pay entry command. Which method you use will depend on your unique situation and the flexibility
you need.
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Set Up Your Income
Your sources of income are called "Pay Sources" in Budget. Pay sources specify the amount and frequency
that you are paid, as well as what bank account the money will be deposited to. Pay source setup is done
when a new budget is being created for the first time or whenever you want to add, remove, or change a pay
source from the budget. See the About Income topic for more information.
To define a new pay source or change an existing pay source, use the Accounts > Pay Source Info... menu
command to display the Pay Source window.
Click on the ADD button to create a new pay source.
Double-click on the name of the pay source to start editing the name. Double-click on the number in the
amount column to change the amount of the pay.

Click on the FREQUENCY pop up menu to change how often you are payed.

Click on the BANK ACCOUNT pop up menu to change the bank account the money will be deposited to.

Page 68 of 152

Repeat this process for each pay source you need.
To remove a pay source, select the item to be removed and click the REMOVE button.
Click the DONE button when you have entered all your pay sources. You can return to this window at any
time to add, remove, or modify your pay sources.
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Rule Based Allocations for Deposits
To access the rule based system for allocating deposited money to envelopes, use the Accounts > Pay/
Deposit Rules menu command.
Note: This dialog records a single transaction regardless of the number of pay sources checked. If you
want to create separate transactions execute the PAY/DEPOSIT RULES command for each pay source.
Pay rules are best used when your pay varies greatly and/or you get paid at different intervals and are never
sure what the amounts will be. The rules are an advanced method to set your budget priorites. Setting up your
own rules will help you make sure your priority expenses like paying the mortgage and putting food on the
table are funded before lesser priority expenses like entertainment. When you set up your rules and enter a
pay or deposit Budget will distribute your money based on the priorities you have set. If there is not enough
money the lower priority items will not be funded. See below for a few examples on how to use the rules
system.
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The Pay/Deposit Rules window is divided into 3 sections. The upper left is the Rule Set section. The upper
right is the Pay/Deposit section. The lower half is the Rule section.
Rule Set Section:
This section displays all defined Rule Sets. The Rule Set section allows you to have a number of different
rule sets. A Rule Set is just a collection of rules. You might have one rule set defined to handle the large
commission check you get and another rule set defined to handle the samll intermediate checks you receive.
You can create a new Rule Set by clicking the "+" button and remove a Rule Set by selecting it and clicking
the "-" button. You can duplicate an entire rule set by selecting it and then clicking the DUPLICATE button.
You can also create Rule Sets based on your existing pays or envelopes by selecting the appropriate selector
in the MAKE RULE SET FROM... popup menu.
When you select a Rule Set all of it's rules are displayed in the table at the bottom of the window.
Pay/Deposit Section:
This section displays your pays in the table, if any are defined for the account selected in the popup menu at
the top. You can also enter a specific amount of a deposit in the fields in this section. Pay(s) and deposit
amounts will be added to form a single deposit transaction. The total amount will be shown at the top of this
section.
Note: You can also change the amount of your pay by double clicking the amount and entering a new
one.
Rule Section:
This section displays all the rules for the selected Rule Set. Each rule is initially shown in it's condensed
format. To show all of the rule's information click the DETAILS button. You can add rules by clicking the "+"
button and remove a rule by clicking it's "-" button. Rules are processed from top to bottom and left to right.
You can reorder rules by dragging them.
The last rule is a fixed rule which can not be deleted. It's present so that any remaining funds in the deposit
that are not distributed by earlier rules goes into some envelope. By default the fixed rule puts the remaining
money into the Available envelope. If you wish, you can change what envelope you'd like to put the
remaining funds in.
Each rule can have a condition which specifies if the rule should execute or not. To set a rule's condition,
click the condition button. The button for a rule can show NOT SET, TRUE, or FALSE based on the current
evaluation of the condition. See the Conditions section below for information about setting conditions.
The AMOUNT field is the portion (allocation) of the pay or deposit to be placed in the envelope. It can be a
fixed amount, the remainder (amount left) in the deposit, percentage of the pay, percentage of the remainder
(amount left) or the same amount as the previous rule.
The TARGET is the envelope that will receive the amount allocated by this rule.
The LIMIT is the maximum amount allowed in the target envelope.
The checkbox for ALLOW PARTIAL determines if the rule should execute if the remaining amount of the
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deposit is less than the amount specified by this rule to be placed in the target.
All rules are evaluated when an amount is entered or a pay is checked in the Pay/Deposit section or when any
part of a rule is changed. The allocation is shown on the right side of each rule. Clicking the RECORD
TRANSACTION button will create the transaction and place the allocations in each target envelope.
Setting Conditions:
Use the first popup menu to select the type of condition. If the type of condition requires a bank account, an
envelope, or both, a popup account box graphic will be displayed where you can select the bank account and/
or envelope. Use the second popup button to select the type of comparison to be done.
Example1:
Jack and Jill are retired and get a regular monthly pension. It is a fixed amount monthly so they set up their
pension as their pay source using the normal Budget pay allocation procedures. However, Jill also has a
part time job that is "on-demaand" and the pay is totally variable. The employer does not withhold taxes
on this pay.
Jack and Jill set up a rule set called "Jills Pay" that they will use each time Jill gets paid. They decide that
the first priority is to set aside money to make a quarterly tax payment on Jill's earnings. The define a rule
to always allocated 20% of the total of Jill's pay to their "Quarterly Tax" envelope. The second priority is
to save for the vacation they want to have next year so they allocate the remainder to their "Vacation"
envelope. In this example Jack and Jill are entering their normal retirement checks using the standard
allocations and Jill's extra income using the rule system.

Example2:
Harry is a consultant and his pay varies widely. he usually has enough money to pay is bills but sometimes
he is short. His first priority is to pay those important non-descretionary bills; rent, utilities, auto insurance,
etc. Next he wants to make sure he has enough money for groceries, gas — things he "needs" to get by. He
would like to have enough left over to go to the movies, travel, eat out, play golf, etc. but he's is willing to
forego some of that to pay the important bills. At the bottom of the list is to save up for a new set of golf
clubs but only if he can afford them.
Harry uses the rules to make sure the top priorities get funded first. His rent is $1000 a month so that is the
number one priority. He knows he will get at least 2 paychecks each month so his first rule defines $500 as
the amount to be placed in the "Rent" envelope. Utilities are generally $80 - $100 per month so his second
rule defines $50 to be placed in his "Utilities" envelope. He continues to create rules based on his highest
priorities. After he has created rules for his priority expenses he estimates that he has about $250 extra per
check to work with. Harry likes to play golf more than anything else so he defines a rule to place $100 in
his "Golf" envelope. Next, he also likes to eat out from time to time so he defines a rule to place $125 in
his "Restaurant" envelope. Lastly, he wants to save for the new golf clubs, but only if he has the money to
do it. He figures there would be about $25 left so he defines a rule to place $25 in his "Golf Club"
envelope.
If Harry's check exceeds his estimates the extra money will automatically go into the "Available"
envelope. However, if there is less then he may not save any money that pay pay for his golf clubs.
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Example3:
Joe and Mary both receive a pay check from their jobs on a regular basis and a fixed amount. They have
been using Budget's regular pay allocation process for months. Now, Joe is laid off and is looking for
another job, but meantime is working part time. His pay comes at variable intervals and amount which are
much less than his previous job. They know Joe will eventually get another job but to tide them over this
period they set up rules so that their important expenses are covered.
Their first priority is to pay their mortgage and other monthly bills. The car insurance is due next month
and they are short in their "Car Insurance" envelope so that is the next priority, gas and food are next. If
anything is left over (probably won't be the case right now), they want it to go into the "Available"
envelope so they can use it as needed.
Note that they did not have to delete their original pay allocations to deviated for a couple of months to use
the rule method. The simply leave the allocations as is but instead of entering their pays with the "Record
Pay" command they use the "Pay/Deposit Rules" command instead. When Joe gets another job they can go
back to using their normal allocations.

Example4:
Mary is self employed as a photographer. She has set up her envelopes for normal monthly bills and has
prioritized her rules for putting money into then. She also wants to put money into envelopes that will help
her manage her business expenses so she has create additional envelopes for "Equipment Purchases",
"Advertising", "Supplies", and the like. To fund these envelopes she has created additional rules. She
decides that the most important of these items is keeping her supplies which normally cost her about $100
per month so she defines a rule that places $100 in the "Supplies" envelope. She also wants to budget some
money for advertising and decides that 10% of whatever is left is a good amount so she defines a rule that
places 10% of the remaining amount into her "Advertising" envelope with a limit of $300 on it. This will
allow the advertising budget to grow but not to much. She then creates another rule to place $100 in her
"Equipment Purchases" envelope. The important thing to note in this example is the limits feature. This
allows Mary to insure that enough money is placed in her envelopes to meet her bills but as she fills them
up more money is left over to pay for the lower priority items.
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Pay Allocation
You set up your pay allocations when a new budget is being created for the first time or whenever you want
to modify the amount of your pay going to an envelope.
To setup your pay allocations use the Accounts > Pay Allocations... menu command to display the Pay
Allocations window. The window has two tabs: "Expense Amount" and "Pay Details". Both tabs allow you to
set your pay allocations. The EXPENSE AMOUNT tab allows you to specify the amount of a bill and how
often it must be paid, and then it computes the amount that should be deducted from your pays. The PAY
DETAILS tab allows you more detailed control over the amount taken from each pay.
If you used the setup assistant or the getting started section to get started, you will see the information you
entered in the budget and pay allocation steps in the EXPENSE AMOUNT tab here.
Note: Changing an envelopes expense amount in the EXPENSE AMOUNT tab resets all of the pay
allocations shown in the PAY DETAILS tab for that envelope. Changing an envelopes amounts in the PAY
DETAILS tab changes the "Monthly" field in the EXPENSE AMOUNT tab for that envelope.

Double click the expense amounts to change them. Use the popup menus to select expense frequency (how
often the bill is due) and which income source to pay the expense.
Notice as you enter amounts next to each of your envelopes the amount next to the "Available" envelope
changes to reflect the monthly amount of money you have left each month. The table in the lower right gives
you a more detailed look at how much money you have left from each of your pays.
You can change the amounts Budget computes for your pay allocations to anything you want by using the
PAY DETAILS tab.
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The PAY DETAILS tab gives you much finer control over the amounts allocated from each pay. You can also
work with pay allocations to individual envelopes, see the Working With Envelopes topic for more details.
Note: Selecting EQUALLY or Proportionally for the pay source will use all defined pays. To select a
subset of pays or to use a percentage of a pay source you must use the envelope's information window.
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Record Your Pay
If you have set up your allocations use the Transaction > Record Pay... menu command or click the
RECORD PAY toolbar button. See the Handling Income section for more information about pay sources and
pay allocations.
If you have not defined any pay sources or have not set up pay allocations for your envelopes, you can
deposit your pay by using a Split Deposit and distribute the amounts to your envelopes manually.

The RECORD PAY window displays a table with a description for each defined pay source.
1. Change the date if desired.
2. Check the checkboxes next to any pay to be recorded.
3. Click the RECORD button if your pay is always the same amount and you do not want to make last
minute adjustments to your envelope allocations.
Your pay will be distributed to your envelopes based on the allocations shown in each envelopes Pay Details
section. If you have set a limit on the amount of money that can be placed in an envelope, any excess over the
limit will be transferred to the "Available" envelope.
Clicking the ADJUST PAY ALLOCATIONS will bring up the Split Deposit window with the pays selected in
the bottom table. You will be able to make adjustments to the total amount of the pay as well as the amounts
going in to the individual envelopes.
Note: Pays entered with the Record Pay window show up in the balance window as separate transactions.
See the Split Deposit topic for entering multiple pays as a single deposit.
You can record your pay at any time. However, the date determines the pay of the month allocations that
Budget uses. For bi-weekly pay sources, dates from the first of the month to the fourteenth of the month are
considered the "first pay of the month", dates from the fifteenth to twenty-eighth day of the month are the
"second pay of the month", and the remaining days are the "third pay of the month". For semi-monthly pay
sources, the first of the month to the fifteenth of the month are considered the "first pay of the month", and
everything else is the "second pay of the month".
As you change the date Budget determines the pay of the month and sets the selector in the table. You can
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override the pay of the month that Budget will use by selecting a different pay in the selector.
Example: If today's date is 4/23/05 when you start the Record Pay command, that date is displayed in the
date field. Assuming that you defined a pay to be bi-weekly, the pay selector would display "2nd Pay".
Changing the date to 4/12/05 would cause the program to distribute the funds according to the definitions
for the first pay of the month. Likewise a pay defined as "weekly" would display as "4th Pay".
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Create Transactions
Transactions in Budget can be created in their own window or in the main window's Transaction Entry form.
To create transactions in their own windows see the specific help section for the type of transaction you want
to create.

Main Window Transaction Entry form
To show the Transaction Entry form on the main window click the Transaction button in the lower left border
of the main window. This button toggles the form on and off the main window. You can also adjust the size
of the form by using the slider between the Envelope Area and the Transaction Entry form.

The Transaction Entry section allows you to create any type of transaction. Selecting accounts and/or
envelopes on the main window determine the settings of the popups. For more information see the
Transaction Entry section.
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Make a Deposit
You can make deposits to any envelope. Deposit transactions increase the amount of money in a bank
account and in an envelope. To record a starting balance or to make a deposit to more than one envelope at
the same time see the split deposit topic.
To make a deposit select the envelope and use the Transaction > Deposit... menu command or click the
DEPOSIT toolbar button.
The deposit transaction window displays the bank account balance in the upper left corner, and the selected
envelope in the upper right corner. If you have more than one bank account defined see the section on
multiple bank accounts.

1. The program places the current date in the DATE field. You may change this if desired.
2. Enter the source of the funds in the RECEIVED FROM field. The field has a popup menu on the right.
If you have written a previous transaction to the account or envelope it will be placed in the field for
you. Budget places a list of previous transactions and entries from the Apple address book in the
popup list. You can enter a few characters and Budget will try to auto fill the field with a similar
previous transaction or an address book entry. You can also use the drop down menu to select an entry
to use. You can click the address book icon next to the field to add a new entry to the address book or
to get the information for the entry if it exists. See the Address Book for more information.
3. Enter the amount of the deposit in the AMOUNT field.
4. Enter any additional information desired in the FOR field. This field is optional.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and hold on
the button to select a currency conversion. The AMOUNT field will be multiplied to the correct amount in the
selected currency. You can set up the quick convert menu and the rates used in the Currency Converter
window.
To set up a future deposit to the same envelope and bank account, turn on the REMIND checkbox. You can
learn more about Reminders.
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When you have all the information entered, click the RECORD button to complete the transaction and return
to the main window or you can click the RECORD AND REPEAT button to enter more deposits in the same
envelope or in different envelopes using the little black arrow in the envelope box.
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Record a Check, Debit, or ATM
Note: The process is basically the same for a check, debit, or ATM transaction. For illustrative purposes
we will use a check transaction. The difference between a check and debit transaction is that a debit does
not have an IDENT field for a check number. The ATM transaction has neither an IDENT field nor a
memo field.
You can record a check from any envelope. Checks decrease the amount of money in a bank account and
envelope. To record a check from more than one envelope at the same time see the split check, debit or ATM
section.
To record a check to pay off a credit card account, see paying off a credit card.
To write a check select the envelope and use the Transaction > Check... menu command or click the
CHECK toolbar button.
The Check transaction window displays the bank account balance in the upper left, and the "Available"
envelope and the selected envelope in the upper right. If you have more than one bank account defined see
the section on multiple bank accounts.

1. The program places the next check number in the IDENT field (Checks only) and the date in the
DATE field. You may change these. Also check the checkbox if the item is tax deductible.
2. Enter the check payee in the PAY TO field. The field has a popup menu on the right. If you have
written a previous transaction to the account or envelope it will be placed in the field for you. Budget
places a list of previous transactions and entries from the Apple address book in the popup list. You
can enter a few characters and Budget will try to auto fill the field with a similar previous
transactionor an address book entry. You can also use the popup menu to select an entry in the menu
to use. You can click the address book icon next to the field to add a new entry to the address book or
to get the information for the entry if it exists. See the Address Book topic for more information.
3. Enter the amount of the check in the AMOUNT field.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and
hold on the button to select a currency conversion. The AMOUNT field will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in
the Currency Converter window.
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4. Enter any additional information desired in the FOR field. This field is optional.
5. For checks, enter any information you want printed on the check in the MEMO field. This field is
optional and is not present for ATM transactions.
6. When you have all the information entered, click the RECORD button to complete the transaction and
return to the main menu.
If there are not enough funds in the envelope to cover the amount of the check you will be prompted to
transfer funds from the "Available" envelope. See the Automatic Transfer from Available topic for more
details.
The RECORD & PRINT button works the same as the RECORD button, but it also sends the check to the
printer to be printed. See the Printing a check topic for more details.
You can click the RECORD & REPEAT button to enter more checks or debits in the same envelope or use the
little black arrow in the envelope box to select different envelopes.
To set up a future check to the same place, turn on the REMIND checkbox. See the Reminders topic for more
details.

Page 82 of 152

Record a Charge
Note: A charge transaction may only be made in an account which has been setup as a Credit Card
account. See the Working With Bank Accounts topic and Getting Started With Credit Cards topic for more
information. When you select the credit card account your envelopes show the amount owed. When you
select the bank account you will use to pay the credit card your envelopes show the amount of money you
have. Deselecting all acounts by clicking in the Total box shows you the "net" amount.

Standard Charge
To record a charge card purchase, select the credit card account. Then select an envelope, and use the
Transactions > Charge... menu command.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and hold on
the button to select a currency conversion. The AMOUNT field will be multiplied to the correct amount in the
selected currency. You can set up the quick convert menu and the rates used in the Currency Converter
window.
The standard charge transaction window displays the credit card balance in the account box in the upper left,
and the selected envelope in the upper right.

Enter where the charge was made in the CHARGE TO field.
Enter the amount of the charge in the AMOUNT field.
Enter any additional information desired in the FOR field. This field is optional.
If this transaction is a refund (or return) check the REFUND checkbox. A refund is actually a deposit to the
credit card account.
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To set up a future Charge from the same envelope and bank account, turn on the REMIND checkbox. See the
Reminders topic for more details.
When you have all the information entered, click the RECORD button to complete the transaction and return
to the main window.
You can click on RECORD AND REPEAT to enter more charges in the same envelope (or a different
envelope by using the popup menu from the envelope graphic).

Split Charge
To record a charge to multiple envelopes, select the credit card account. If you want to work with specific
envelopes select multiple envelopes then use the Transactions > Split Charge... menu command. If you
wish to work with all envelopes, make sure none of the envelopes are selected and then use the Transactions
> Split Charge....
The Split Charge window displays the credit card balance in the account box in the upper left. A list of
envelopes is displayed in a table at the bottom of the window. To show all envelopes check the box

Enter where the charge was made in the CHARGE TO field.
Enter any additional information desired in the main FOR field. This field is optional and will be displayed
with the transaction placed in the credit card's account history window.
Double click an amount in the table next to each envelope to enter amounts. As you enter amounts in the
table the total amount will be displayed in the main AMOUNT field. See the entering information in split
transactions topic for more information.
Double click the FOR field next to each envelope in the table to show what this portion of the charge was for.
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To set up a future Split Charge from the same envelopes and bank account, turn on the REMIND checkbox.
See the Reminders topic for more details.
When you have all the information entered click the RECORD button to complete the transaction and return
to the main window.
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Paying off a Credit Card
If you have set up your credit card as an account in Budget, after balancing your credit card account you can
write a check or debit to pay the credit card bill. To do so, on the main window drag from the bank account
you want to write the check (or debit) from to the credit card account.
The Account Check transaction window displays the bank account the money is coming from in the upper
left, and displays the credit card account to pay in the upper right.

Note: The only difference between a check and debit is that a debit does not have an ident
field.
To set up a future check to the same place, turn on the REMIND checkbox. You can learn more about
Reminders.
The account check window displays a list of your envelopes. If you have made a previous account check that
checks information and the envelopes used are displayed. To work with all the envelopes check the box for
SHOW ALL ENVELOPES. Fill out the top of the section of the window like you would for a standard check,
leave the AMOUNT field blank.
1) Enter the check payee in the PAY TO field.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and hold on
the button to select a currency conversion. The AMOUNT field that you last edited will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in the
Currency Converter window.
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2) Enter any additional information desired in the FOR field. This field is optional.
3) For any information you want printed on the check in the MEMO field. This field is optional.
4) The program places the next check number in the IDENT field (Checks only) and the date in the DATE
field. You may change these. Also check the appropriate box if the check is tax deductible.
5) For checks written to a credit card account you will see a popup menu and a table in the bottom half of the
check window. Enter the amounts you want to pay from each envelope in the last column.
The table lists the envelopes that have charges due, the amount in that envelope for the account from which
you are writing the check, and the amount in that envelope that is due. The next to last column is the amount
you want to pay from that envelope for the credit card account. The total of all values in the PAY
AMOUNT column is placed in the check amount field at the top. The last column has a checkbox which is
only displayed if the amount of the payment is greater than the amount in the envelope. Check the checkbox
if you want an available transfer to be done. You can click the column header to check or uncheck all the
boxes. See the Automatic Transfer from Available topic for more details.
The pop up menu is used to initialize the PAY AMOUNT column in the table. Currently there are 5 selections.
These selections may be used to setup the amounts you want to pay for each envelope based on whether you
want to pay off the total debt, pay off the charges for that months bill, pay off a specific amount you have
allocated to each envelope etc. You may have to edit specific amounts by double clicking the amount in the
PAY AMOUNT column to set it to whatever amount you want to pay from that envelope.
●

●

●

●

●

Initialize - Places $0.00 in the PAY AMOUNT column. Usage: Clears all the amounts and allows you
to enter any amount you choose next to each envelope.
Pay Total Amount Owed - Places the total amount charged to each envelope in the PAY AMOUNT
column. Usage: Choosing this option will effectively pay off your entire credit card debit regardless of
what was on your statement.
Pay Balanced Charges or Total Credit Amount Owed - For envelopes that have unbalanced
transactions, only the total amount of balanced transactions are placed in the PAY AMOUNT column.
If all transactions are balanced (i.e no activity in the envelope) then the total amount owed is placed in
the PAY AMOUNT column. Usage: Best for paying charges made since the last statement or the total
old debit.
Pay Balanced Charges or Total Amount In Envelope - For envelopes that have unbalanced
transactions, only the total amount of balanced transactions are placed in the PAY AMOUNT column.
If all transactions are balanced (i.e no activity in the envelope) then the total amount in the envelope
for the account being used to pay the bill is placed in the PAY AMOUNT column. Usage: Best for
paying charges made since the last statement and paying down old debit.
Pay Balanced Charges or Total Amount Allocated to Envelope - For envelopes that have
unbalanced transactions, only the total amount of balanced transactions are placed in the PAY
AMOUNT column. If all transactions are balanced (i.e no activity in the envelope) then the total
amount allocated to the envelope for the account being used to pay the bill is placed in the PAY
AMOUNT column. Usage: Used for paying charges made since the last statement and a constant
amount for paying down old debit

6) When you have all the information entered click the RECORD button to complete the transaction and
return to the main menu.
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The RECORD & PRINT button works the same as the RECORD button but also sends the check to the printer
to be printed. See the Printing a check topic for more details.
Example 1: You want to write a check to your First Card for $250.00. You would enter "First Card" in the
PAY TO field, and "Payment" in the FOR field. You can also put your account number (if desired) in the
MEMO field. You would then select option one in the popup menu to place $0.00 in the PAY AMOUNT
column then enter amounts till you have the total of $250.00 showing in the AMOUNT field. Since you
want a check printed you would click on RECORD & PRINT button to complete the transaction and return
to the main window.
Example 2: You want to write a check to your First Card that pays off the charges you just made since
your last statement. First, balance your credit card account if you have not already done so. See the
Balance your account topic for more details. Enter the standard fields for the check and then select option
3 PAY BALANCED CHARGES OR TOTAL CREDIT AMOUNT OWED from the popup menu. This option
will place the amount of the transactions you just checked off in the balance process next to each envelope,
effectively paying the total charges for the month.
Example 3: You want to write a check to your First Card that pays off the charges you just made since
your last statement and pays down your existing debt. First balance your credit card account if you
have not already done so. See the Balance your account topic for more details. Enter the standard fields for
the check and then select option 4 PAY BALANCED CHARGES OR TOTAL AMOUNT IN ENVELOPE
from the popup menu. This option will place the amount of the transactions you just checked off in the
balance process next to each envelope, effectively paying the total charges for the month just like in
Option 3 above. However, it will also look at any envelopes that has an amount owed in the credit card
account, and has had no activity (no new charges) and finding one will place the current balance in that
envelope for the account used to pay the bill as the amount to pay.
Further description for paying down existing debt options 4 and 5
You have created an envelope to hold your existing debt. See the Getting started with credit card accounts
topic for more details. The payment options assume that in some manner you have placed money into the
envelope to pay down the debt. In option 4 you have done that by some combination of pay allocations,
deposits, etc. In option 5 the total amount of the pay allocations to that envelope in the checkbook is used.
Let's say that you have the "Existing Debt" envelope and it has a $3000.00 debt in the credit card account.
You have an "Entertainment" envelope where you charged $100 for dinner this month. Showing the credit
card account on the main window these two envelopes would show their balances as negative numbers. In the
checkbook you also have money in these envelopes. Let's say you have $200 in the "Entertainment" envelope
and $50 in the "Existing Debt" envelope. Showing the checkbook account on the main window these two
envelopes would show $200 and $50 respectively. You get your credit card bill, it shows one charge for
$100, you select the credit card account and click the BALANCE toolbar icon. You enter the statement
balance in the top right, check off the $100 charge in the table and balance the account. Note, the existing
debt does not show as a transaction in the credit card statement; it did that long ago when you made the
charge. Now it is only reflected in the total amount you owe.
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With the credit card account balanced you go to pay the credit card bill by dragging from the checkbook
account to the credit card account on the main window. You select Option 4 and Budget places the $100 next
to the "Entertainment" envelope and $50 next to the "Existing Debt" envelope.
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Split Deposits
A split deposit is used for two purposes in Budget.
1. To make a single deposit that is distributed to more than one envelope. The split deposit is also used when
you record a starting balance in your Account, when you deposit your pay and distribute it manually to your
envelopes, or when you make pay allocation adjustments to a fixed or variable pay when using the Record
Pay command.
2. When recording a number of checks that were deposited in the bank with one deposit slip. Your bank
statement will reflect one deposit for the total amount, and in Budget it will also show up as a single deposit
in the balance window, which allows you to easily find it when balancing the bank account. You will also be
able to distribute the total deposit amount to your envelopes.
To enter a split deposit to a small number of envelopes, first select the envelopes. If the deposit is to be
distributed to most or all envelopes, select the bank account, then use the Transaction > Deposit... menu
command or click the DEPOSIT toolbar button. The envelopes will be displayed in the split deposit window.
You can toggle between the selected envelopes and all envelopes by clicking the "Show all envelopes" box.

The split deposit transaction window displays a list of your envelopes and a list of your pay sources. If you
have made a previous deposit that deposit's information and the envelopes used are displayed. To work with
all the envelopes, check the box for SHOW ALL ENVELOPES.
Budget places the amount of the last transaction in the AMOUNT field or $0.00 if no transaction was found.
Double click an amount in the table next to each envelope to enter amounts. If there is an amount in the
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AMOUNT field as you enter amounts next to each envelope the amount left to be distributed is shown. If
there is no amount in the AMOUNT field as you distribute amounts to your envelopes the amount field will
show the total distributed. See the entering information in split transactions topic for more information.
Enter where the funds came from on the RECEIVED FROM field and what they were for in the FOR field.
This information will be shown in the account's history window.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and hold on
the button to select a currency conversion. The AMOUNT field you last edited will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in the
Currency Converter window.
Change the date if desired. Which pay of the month is used is based on the date; see the Recording Your Pay
topic for more information.
Checking a pay will place the correct allocation for this pay next to each of the envelopes. You may then
change any amount as needed.
Example 1: You received a check as a gift and have a refund from your medical insurance that you want
to make as a single deposit. Select the two envelopes and click the DEPOSIT toolbar button. The two
envelopes will be shown in the table. Double click the amount field next to the "Medical" envelope and
enter the amount of the refund. Enter "Insurance Co. Name" in the FROM field and enter "Refund" in the
FOR field. Do the same for the other check. Once you have everything the way you want click the
RECORD button.
Example 2: For variable pays.
You have your current pay check and it is less than the amount you have allocated to all your envelopes. In
the bottom list check the pay you have just received. Notice the amount you have allocated to each of your
envelopes is placed in the table above next to each envelope. Now you must decide which envelope must
receive less (your pay check was less). Suppose that you decide that your "Entertainment" envelope which
currently has an allocation of $50 will have to be $20 for this pay. Next to "Entertainment" in the top table
change the $50 to $20. Repeat this process until the amount shown at the top matches the amount of your
check. Once you have everything as you want, click the RECORD button.
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Split Checks, Debits, and ATMs
Note:The process is basically the same for a check, debit, or ATM transaction. For illustrative purposes
we will use a check transaction. The difference between a check and debit transaction is that a debit does
not have an IDENT field for a check number. The ATM transaction has neither an IDENT field nor a
memo field.
You can split the amount of a check among multiple envelopes. This is useful when you purchase a number
of items with a single check. For example, you may have purchased both groceries and drugs at the local
supermarket and want to split the amount of each purchase in your "Grocery" and "Prescriptions" envelopes.
To split a transaction among multiple envelopes select the bank account and use the appropriate
Transactions menu command. If you have more than one bank account defined see the Multiple Bank
Accounts topic for more information.

Note: You can change the type of transacton by selecting the transaction type radio button.

The split check transaction window displays a list of your envelopes. If you have made a previous split check
that checks information and the envelopes used are displayed. To work with all the envelopes check the box
for SHOW ALL ENVELOPES.
1. Enter the check payee in the PAY TO field
2. Enter any information you placed on the check in the MEMO field (optional).
3. The program places the next check number in the IDENT field and the date in the DATE field. You
may change these. Also check the main Tax Item checkbox if the entire transaction is tax deductable.
Page 92 of 152

Check the box for each envelope in the last column if a portion of the split is tax deductable.
4. Double click an amount in the table next to each envelope to enter amounts. Also enter data in the the
FOR field (optional) for each envelope. As you enter amounts the total will be shown in the check
area amount field.
Budget places the amount of the last transaction in the AMOUNT field or $0.00 if no transaction was
found. If there is an amount in the AMOUNT field, as you enter amounts next to each envelope the
amount left to be distributed is shown. If there is no amount in the AMOUNT field as you distribute
amounts to your envelopes the AMOUNT field will show the total distributed. See the working with
table amounts topic for more information.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and
hold on the button to select a currency conversion. The AMOUNT field will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in
the Currency Converter window.
5. Once all the information is correct, click the RECORD button, or the RECORD AND PRINT button if
you would also like to print the check on your printer.
Note: Available Transfer
A checkbox will be displayed in the last column if the amount of the check is greater than the amount in
the envelope. Check the checkbox if you want funds to be transferred from the "Available" envelope to
cover the check.
The checkbox in the header of the last column can be used to turn all the checkboxes on or off. See the
Automatic Transfer from Available topic for more information.
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Record a Transfer
There are several types of transfers that can be recorded.

Transfer between envelopes
You can easily move funds from one envelope to another or from one account to another. To transfer funds
use drag-and-drop. Click and hold the mouse button on the source envelope. Drag the mouse to the
destination envelope and release. If you drag the mouse over an envelope group and wait a second, the
envelope will spring open and you can drop the transfer on one of the sub-envelopes of the envelope group.

1. Enter the amount to transfer in the AMOUNT field.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and
hold on the button to select a currency conversion. The AMOUNT field will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in
the Currency Converter window.
2. Enter any additional information desired in the FOR field. This field is optional.
3. The program places the current date in the DATE field. You may change this if desired.
4. When you have all the information entered click the RECORD button to complete the transaction and
return to the main window.
Example: You want to transfer $47.25 from your "Entertainment" envelope to your "Visa" envelope. In
the transaction window enter "$47.25" in the AMOUNT field. In the FOR field enter the reason for the
transfer such as "Dinner at TGI Friday's".
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Automatic Transfer from Available envelope
Budget automatically brings up the Available envelope transfer window whenever you attempt to take more
funds out of an envelope than currently exist. This will happen either when writing a check or when doing a
normal transfer of funds.

1. The program automatically fills in the AMOUNT field with the shortage from the initial transaction
(check or transfer). You may change this amount if you want to transfer any additional funds at this
time.
2. The program places the current date in the DATE field. You may change this if desired.
3. When you have all the information entered click the RECORD button to complete the transaction and
return to the main window.
This transaction window differs from most others in that there are two different methods for cancelling the
transaction. The first is CANCEL. If you click on this button the preceding check or transfer (the action that
got you here in the first place) will be cancelled along with this transfer.
If you click on the CANCEL AVAILABLE TRANSFER ONLY button then only this transaction will be
cancelled and the original transaction will be completed which will cause the envelope to go negative.
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Example: You tried to write a check for $310.00 from your "Medical" envelope but the current balance in
the "Medical" envelope was only $240.00. When you clicked on the RECORD button for the check the
Available Transfer transaction window was displayed with $70.00 in the AMOUNT field and today's date.
If you now click on RECORD $70.00 will be moved from the "Available" envelope to the "Medical"
envelope. Then the check action that you originally started with will be completed. This would then leave
you with a balance of $0.00 in the "Medical" envelope.
If you clicked on the CANCEL AVAILABLE TRANSFER ONLY in the above example, then the original
check transaction would be completed, the transfer from the Available envelope would be cancelled, and
the account in the "Medical" envelope would show a balance of $-70.00.

Transfer between bank accounts
Drag within the same envelope (from one side to the other) to transfer money between accounts within that
envelope or drag between accounts to transfer money between accounts in multiple envelopes.

1. Enter the amount to transfer from each envelope in the tables AMOUNT column. The total will be
shown in the main AMOUNT field.
2. Enter any additional information desired in the FOR field. This field is optional.
3. The program places the current date in the DATE field. You may change this if desired.
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4. When you have all the information entered click the RECORD button to complete the transaction and
return to the main window.
Example: You want to transfer $400.00 from your "Savings" account to your checkbook and you want
$200 to be move within the "Grocery" envelope and $200 to be moved within the "Medical" envelope. In
the table double click the amount next to the "Grocery" envelope and enter the $200 in the AMOUNT
column. Do the same for the "Medical" envelope. In the FOR field enter the reason for the transfer such as
"Money need to meet bills".
Note: Available Transfer
A checkbox is displayed in the last column if there is not enough money in the "From" envelope to cover
the transfer. If the amount of the transfer is greater than the amount in the envelope, check the checkbox if
you want funds to be transferred from the "Available" envelope to cover the initial transfer. See the
Automatic Transfer from Available envelope section above for more details.
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Transaction Entry Form
You can use the Transaction Entry Form on the main window to enter any type of transaction. To show the
form click the TRANSACTION button in the bottom left of the main window. Click it again to hide the form.
You can record transactions in their own windows by either using the Transaction menu or clicking the
appropriate toolbar icon. See the specific transaction help for more information about creating that type of
transaction.

The form has three areas, the Transaction area which is always shown, the Split area which is shown when
creating a split transaction or the Calendar area which is shown for standard transactions.
The Transaction Type selector at the top left of the form controls which buttons and fields are shown based
on the type of transaction being created. See the configuration section below for which buttons and fields are
shown for each type of transaction. The Transaction Type selector defaults based on Account/Envelope
selections. See the Transaction defaults section below. You can select any type of transaction at any time.
The Date Field is at the top right of the form. Select any portion of the date and use the up/down button or the
keyboard arrow keys to change the date. The little black down arrow to the left of the field always sets
"today" in the date field. As you make changes to the date the calendar will update. You can also use the
calendar to set dates.
The next two lines are the Account and envelope selectors. These vary based on the type of transaction
selected and default to the selected accounts/envelopes on the main window.
Next line is the Amount field (Required), currency conversion, tax item and reminder checkboxes. If you
have set your preferences to work with Apple's Address Book you can click the Address Book icon to
retrieve or save information. The Paid To Received From field has a selector which shows previous
transactions based on the transaction type and Account/Envelope selectors.
Bottom line is the Split buttons. You can add a split to any transaction by clicking the Plus (+) button. You
can remove a split by selecting it in the split table and clicking the Minus (-) button. At the bottom of the split
table is the remaining amount to be distributed message and a button to clear all fields in the split. Click
either of the Record buttons to record the transaction.
Page 98 of 152

Calendar Section
The calendar section shows reminders and To Do's you have created. Select the reminder you want to create
and the table and click the Record button to record it.
Note: Unless you are showing the history and statistics for the reminder transactions envelope you will not
receive any feedback that the transaction was created. You can verify that it was created by selecting the
reminders envelope on the main window to show the history.

Click the Icon for iCal to update your iCal calendar. Select "Show All" to show all your reminders in the
table or "Show Due" to just see the ones that are due within the warning period. Click the Settings button in
the lower left of the main window to change the warning period, reminder frequency, or to skip a due
reminder. Click the Record button to record a due reminder or select a reminder in the table and click the
Delete button to remove it. Click the New button for a new To Do or select on in the table and click the
Remove button to remove it. Click the Info button in the first column to show more information about the
reminder. Double click the date to edit and change the due date.

Transaction Defaults
The selection normally defaults to either a check or debit based on the accounts preferences but it can also
default based on the current Account/Envelope selections on the main window. Selecting a single envelope
defaults to either check or debit. Selecting 2 envelopes defaults to a transfer. Selecting more than 2 envelopes
or a group envelope defaults to a split check or debit. Selecting two accounts to an account transfer. Selecting
a checking and a credit card account to a account check (Credit card payment).

Button, Fields and Split Table Configurations for Transaction Type
Checks
Check Number, Date, Account Selector, Envelope Selector, Amount, Currency Conversion, Tax Item,
Reminder, Address Book, Paid To/Received From, For, Memo, Add Split (+), Remove Split (-), Record and
Print, and Record.
Debits
Same as Check but without the Check Number field.
ATM
Same as Debit but without the Record and Print button.
Deposit/Refund
Same as ATM but without the Memo field.
Transfer
Date, Account Selector, First Envelope Selector, Second Envelope Selector, Amount, Currency Conversion,
Tax Item, Reminder, For, Add Split (+), Remove Split (-), and Record.
Account Transfer
Date, First Account Selector, Second Account Selector, Amount, Currency Conversion, Tax Item, Reminder,
Address Book, Paid To/Received From, For, Memo, Add Split (+), Remove Split (-), Record and Split Table.
Charge
Same as ATM
Credit Card Payment Check
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Check Number, Date, First Account Selector, Second Account Selector, Payment Selector, Amount,
Currency Conversion, Tax Item, Reminder, Address Book, Paid To/Received From, For, Memo, Add Split
(+), Remove Split (-), Record and Print, Record, and Split Table.
Credit Card Payment Debit
Same as Credit Card Payment Check but without the Check Number field.
Any Defined Pays
Pay Number, Date, Amount, Currency Conversion, Reminder, Paid To/Received From, For, Memo, Add
Split (+), Remove Split (-), Record, and Split Table.
Split Table Columns
Check/Debit/ATM, Envelope Name, Amount, For, and Available Transfer checkbox based on account
preferences setting.
Deposit/Charge, Envelope Name, Amount and For.
Account Transfer/Pays, Envelope Name, Amount, Source Account balance.
Credit Card Payments, Envelope Name, Amount, Credit Account balance.
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History Window
To show an envelope history select the envelope and use the Envelopes > Envelope History menu command
or click the ENV HISTORY toolbar button.
For envelope histories, you can use the popup menu in the top left of the window to show all history records
or select a particular bank account to show only it's history records.

To show a bank accounts history, select the account and use the Accounts > Account History menu
command or click the ACCT HISTORY toolbar button.
Note: To display all transactions in a bank account (similar to a check register), display the account
history. Turn on the checkbox for SHOW ALL TRANSACTIONS.
To print a report of the currently displayed transactions click the DISPLAY SETTINGS button and then click
the PRINT TRANSACTION REPORT button. The transactions shown in the history window are use for the
report.
Double clicking a transaction will bring up the transactions information window. The transaction information
window shows all information about any transaction. It also has EDIT, VOID, and DELETE buttons which
allows you to easily work with the selected transaction.
Reminders
You can set a reminder on a transaction. Select the transaction in the history window and click the Alarm
Clock icon. This will set the reminder status for the transaction. You can then view the reminder in the
Calendar. To remove the reminder show the calendar, select the transaction, and then click "Delete".
Sorting
Click the column header to sort the transactions by that column. The envelope transaction history can be
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sorted by any column except the BALANCE column. You can change the triangle indicator to sort columns in
either ascending or descending order by clicking it. In addition the date column can also be sorted in original
entry order (no triangle indicator).
The account history window can also be sorted by any column except the BALANCE column. However, if
you show all transactions in the account history they will also be sorted by date.
Limiting displayed transactions
Use the SEARCH field to find matching history records. The search will match any text field of the
transaction to the search text that you enter; the search is not case sensitive. On Mac OS X v10.3 and later,
the search field contains a popup menu that can limit the search to particular fields of the transaction.
You can limit the transactions displayed by a date range. Use the date range popup to set predefined date
ranges or set the starting and/or ending dates to any date you want. Information about the transactions
displayed is shown directly below the date range popup menu.
To filter additional transactions click the DISPLAY SETTINGS button to display the settings drawer.

By default all transaction types are displayed in the history window. You can selectively decide which
transaction types should be shown by checking the boxes. Transaction types that are check are displayed in
the history window. You can also decide to show transactions based on their Balanced, User, or Tax status.
Click the PRINT TRANSACTION REPORT button to get a transaction report of the displayed transactions.
See the Reports section for more details.
Note: Click the header of the first column to expand/collapse all
transactions.
You can also use the Find Transaction command to find transactions anywhere in the entire document.

Page 102 of 152

Finding transactions
All transactions are kept in the history file. You can find information based on who the transaction was "Paid
to" or "Received from", what it was "For", the "Memo" on the check or the "Amount" of the transaction. You
can also find information by many other criteria.
To search for transactions use the Edit > Find Transaction... menu command.
If you have not registered Budget, you will not be able to add more than one criteria to the search. For more
information about registering Budget, click here.

Select the type of information by using the two pull down menus in the CRITERIA section, then enter the
specific information you want to search for in the search fields. You can add or remove criteria for more
complex searches.
Use the AND/OR radio buttons to set whether the criteria is to be "And" or "Or" type.
Once you have set your criteria click the SEARCH button. The results will be displayed in the bottom half of
the window. Only accounts/envelopes with hits are shown in the list.
You can double-click a transaction in the results table to open the relevant envelope history window with that
transaction selected.
Click the EXPORT button to export the found transactions. See the Exporting Transactions topic for more
information.
Note: When searching for strings of information the IS EQUAL TO option is case sensitive, while the
CONTAINS option is not.
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Editing a Transaction
You can edit transactions to change information in any field. To edit a transaction select it in a HISTORY
window by clicking it once. Then use the Transactions > Edit... menu command. You can also double click
the transaction to show the transaction's details and then click the EDIT button. This will bring up the
transaction window for the transaction being edited. That is, if you are editing a deposit you will see the
transaction information displayed in the deposit window. However, the RECORD button has been changed to
a SAVE button.
You can also change a transaction's envelope or account. To change the account use the pull down menu in
the window's account box (upper left). To change the envelope use the pull down menu in the window's
envelope box (upper right). Click the SAVE button when done.
Note: You can not edit the checkbook history log
records.
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Void a Transaction
To void a transaction, click once in the history window to select the item to be void, then use the
Transactions > Void menu command.
Do not confuse the "Void" process with "Undo". The "Undo" process is used to forget the last completed
action. An example of Undo is you enter a To Do item in the calendar. Then you realize that the item has
already been completed. You could either delete the To Do, or simply undo it using the Edit > Undo menu
command.
The void process is used in the event a transaction has not cleared your bank. The best example is, you
receive a check from a friend which you deposit to your bank and record in the Budget program. A few days
later, the bank informs you that the check was returned for insufficient funds. In this case you would find the
transaction in the correct envelopes history window and void it.
Note: The history window transaction record is updated with the "Void" icon to reflect that the transaction
is void, but not removed from the history window. See the Delete a Transaction topic for more info on
how to remove it from the history window.
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Delete a Transaction
To delete a transaction from an envelopes history list, select the transaction by clicking it once. Then use the
Transactions > Delete menu command. This will completely remove the transaction from Budget.
Note: If you delete a transaction that has not been void, you will see a warning message. You can turn off
the warning message by clicking the DON'T SHOW AGAIN checkbox.
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Address Book Integration
If running on MacOS X 10.2 or later, the Budget program interfaces with Apple's Address Book application.
You can save information about the transactions you made in the address book. Address Book records are
added to the popup menu in the PAY TO/RECEIVED FROM field along with previous transaction records
when you create transactions. You can select an item from the popup menu or just type a few letters in the
field to select items in the popup.
To access the Address Book information, either select an item from the PAY TO/RECEIVED FROM field or
enter a name in the field, then click the Address Book icon to the left of the field. If the information exists in
the Address Book for the name you entered, it will be displayed in the window. If it does not exit, then place
holders will be displayed.

Double click any field to start editing the information in that field. Click the SAVE button to record any
changes.
The COMPANY checkbox must be checked in order to use the ACCOUNT NUMBER and CONTACT fields.
Company names must be placed in the FIRST NAME field only.
Any records that you add to the address book will also show up in a group in your address book named
"Budget".
There are a few settings that you can change to affect the way Budget interfaces with Address Book. See the
Preferences section for more information.
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The Currency Converter Window
The Currency Converter window can show an amount in one currency converted into many other currencies.
You can also set up the Quick Convert popup menu and edit the currency conversion rates from this window.

Enter a number in the field at the top and choose a currency from the popup menu on the right. The table
displays that amount converted into each of the currencies that Budget knows about.

The Quick Convert Popup Menu
Place a check mark in the QUICK column to place a specific conversion into the Quick Convert popup menu.
A sample Quick Convert popup menu appears at the top of this window so you can see all of the conversions
you have placed in it. The various transaction windows in Budget (check, deposit, ATM, etc) also have a
Quick Convert popup menu that adjusts the amount field for that transaction by the selected conversion rate.
Example: Select the "Euro" from the popup menu at the top of the window and check the "Brazilian Real"
line in the table. This places a "Euro to Brazilian Real" conversion in the Quick Convert menu. To also
add the "Brazilian Real to Euro" conversion, select "Brazilian Real" from the popup menu at the top of the
window and check the "Euro" line in the table.

Currency Exchange Rates
Budget ships with built in average currency exchange rates that are current at the time it ships. You can
download updated rates stored on the Snowmint Creative Solutions web site using the EDIT RATES drawer.
The Snowmint web site will generally have rates that are one to two days old. New currency rates can be
downloaded automatically by the automatic update feature of Budget.
Warning: The currency exchange rate data shipped with Budget and downloaded from the Snowmint web
site is obtained from sources believed to be reliable but Snowmint Creative Solutions LLC does not
guarantee it's accuracy, completeness or correctness.
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The exchange rates are all in terms of $1.00 U.S. Dollar. The exchange rate information can be edited directly
in the table in the EDIT RATES drawer. New currencies can be added and currencies that are irrelevant can be
removed from the list.
Any updated rates that are downloaded or entered are stored on the system hard drive in the /Library/
Application Support/Snowmint folder. If that folder can not be written to (due to user permissions)
the updated rates are stored in the home/Library/Application Support/Snowmint folder for the
current user. If that folder is also read only, then the updated rates are only stored in RAM until Budget is quit.
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Calendar
The calendar can be displayed by using the Tools > Calendar... menu command.
The calendar window is used to show Budget reminders and To Do items. On the right side of the calendar
are two lists. The top list shows the selected day's due reminders if any, and the bottom list shows that day's
To Do items if any.
Click on a specific date to show To Do items and Reminders (repeating transactions) for that day. A date with
a scheduled To Do item is displayed with a green (by default) triangle covering the lower right half of the
date. A date with a scheduled reminder transaction is displayed with a yellow (by default) triangle covering
the upper left half of the date. Reminders and To Do items that are overdue will be displayed in red by
default. You can set what colors you want the calendar window to use in the Colors preference pane.
Click on the arrows to the top left and top right of the calendar to change the month. You can also choose the
month from the popup menu at the top of the window. You can select a different year by typing the complete
year (with century) into the text field.
Check the box at the top of the reminder list to work with all your reminders
If there are any due (or overdue) reminders or To Do items, the calendar window will be displayed when you
open a document. There is a preference setting for always displaying the calendar when you open a Budget
document.

Synchronize with iCal
iCal is Apple Computer's calendar application for Mac OS X. If Budget is running on Mac OS X v10.2 or
later, you can easily have iCal display Budget reminders and To Do items.
Simply click the UPDATE ICAL button on the calendar window, and iCal will be launched (if it's not running
already) and data on all reminders and To Do items will be passed over to iCal. Within iCal, a calendar
named "Budget" will be created to contain all of these items.
Warning: If a calendar named "Budget" already exists, when the UPDATE ICAL button is clicked, all
existing items will be removed from the "Budget" calendar within iCal before the current items are added.
This keeps iCal up to date, but will result in data loss if you have added items to the "Budget" calendar
within iCal by hand.
There is also a preference setting available to have Budget automatically update iCal any time a reminder is
created, changed, or recorded. Using this feature, iCal will be launched (if it wasn't running already) and it's
"Budget" calendar will be updated with the new information.
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Reminders: Repeating Transactions
Reminders provide a method for the Budget program to tell you when repeating/recurring transactions are
due. Almost any Budget transaction can have a reminder set. Reminders are transaction based, not envelope
based. That means that an envelope can contain more than one transaction with a reminder. However, similar
transaction types must have different FROM/TO fields to be considered different reminders (see the note
below).
Reminders that are due are displayed in the reminder table on the calendar window each time you start the
Budget program. A date with a scheduled reminder transaction is displayed with a yellow (by default)
triangle covering the upper left half of the date. Reminders that are overdue are displayed in red by default.
See the Calendar section for more information.
Reminders on the main window
The main window and group windows also display reminder information. Reminders set for single envelope
transactions will display an icon in the lower right corner of their envelope. Reminders set for split
transactions will display an icon in the lower right corner of the bank account that they are in.
The reminder icon will be colored differently depending on when the reminder is due. If the reminder is
overdue, the icon will be red. If the reminder is within it's due date warning period, the icon will be yellow. In
any other case, the reminder icon will be white. You can change the colors for overdue reminders and
reminders in their due date period by using the preferences.
Clicking the reminder icon in the envelope or bank account will display the calender window. The calendar
window will be set to show the oldest reminder that is due for that envelope or account.

Setting a Reminder
You can set reminders on almost any type of transaction. When you are recording a transaction, simply check
the REMIND checkbox. You can also set reminders for already recorded transactions. In any history window,
select the transaction you want to be reminded about, and then click the REMINDER toolbar button to set the
reminder.
The calendar window will open with the date of the reminder set on the calendar and the transaction in the
reminder table. The details of the reminder are displayed on the info panel at the right side of the calendar
window.
A reminder icon will be displayed in the history window next to any transaction with a reminder. Each time
you record a reminder transaction, the icon will move to the new transaction and the timers will be reset.
When the reminder is due, it will displayed in the calendar window.
When setting reminders from a history window, you should set them on the most current matching
transaction. If you attempt to set a reminder on a transaction that is too old instead of the most current one,
Budget will actually set it on the most current one (the reminder icon will show up on the most recent
matching transaction in the history list).
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Note: Budget uses the transaction type and the FROM/TO field to determine if a reminder transaction is
satisfied. That is, if you have set a reminder for a check to "GE Capital Mortgage Service" whenever you
write a check from the same envelope with "GE Capital Mortgage Service" in the TO field, Budget will
consider the reminder satisfied. You can have a separate reminder for a deposit transaction to "GE Capital
Mortgage Service" because the transaction type is different.
Example: Assume you have been writing checks to the "GE Capital Mortgage Service" each month. If
you set this up as a reminder, each time you record a reminder check for "GE Capital Mortgage Service"
the reminder icon in the history window will move to the most current transaction.

You can change the following attributes of any reminder.
●
●

●

The due date for this transaction.
The number of days prior to the due date that you want to be reminded (the calendar window will
display the reminder if any date is selected during this time period).
The frequency of the reminder.
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Example: Today is April 26, 2004. You are writing the check to the mortgage company that is due on
May 1, 2004. You want to be reminded each month to make this payment. When recording the transaction
in Budget for this month, check the REMIND checkbox and click on RECORD. The calendar window will
be displayed with the reminder information in the side panel.
Budget assumes a monthly reminder and sets the date one month from April 26. However, since you wrote
this check 5 days before it was due you may want to change the reminder date to be the actual due date, so
you select 05/26/04 and change the date to 06/01/04. Next you decide that you want to be notified 7 days
prior to the first of each month, so you enter a "7" in the REMIND DAYS BEFORE field. Since this is a
monthly bill, you leave MONTHLY selected.

Recording a Reminder Transaction
You can double-click on an item in the reminder table to bring up its transaction window to record the
transaction. You can also select the reminder, then click the RECORD button. When you have entered the
transaction, it will no longer be displayed in the reminder window unless you leave the REMIND checkbox
checked.

Synchronize with iCal
iCal is Apple Computer's calendar application for Mac OS X. If Budget is running on Mac OS X v10.2 or
later, you can easily have iCal display Budget reminders. See the Calendar topic for more information.
There is a preference setting available to have Budget automatically update iCal any time a reminder is
created, changed, or recorded. Using this feature, iCal will be launched (if it wasn't running already) and it's
"Budget" calendar will be updated with the new information.
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Setting To Do Items
The Budget program supports a different To Do list for every day. To Do items can be created at any time by
using the Calendar window. Use the Tools > Calendar... menu command. See the Calendar topic for more
information.

To display To Do items, click on the scheduled date in the CALENDAR window. A date with a scheduled To
Do item is displayed with a green (by default) triangle covering the lower right half of the date. You can use
the Colors preference pane to change the color of To Do scheduled triangle.
To create a To Do list, first click on a date in the calendar. You can click the ADD TO DO button to add as
many To Do items as you wish. To delete a To Do item, select it and then click the DELETE TO DO button.
Notes:
1. You can not create a To Do before today.
2. The calendar window displays the To Do list for the date selected in the calendar or the current date
if nothing is selected.
3. The calendar window will be shown when the document is opened if a To Do is due.
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Using the Investment Section
Budget provides a simple means of tracking your investments based on the same means of displaying
information as the budget windows. An investment in Budget can be used to represent anything that has a
price per share and a number of shares, including stocks and mutual funds. To enter the investment section of
the Budget program, use the Tools > Investment... menu command.
The INVESTMENT window shows information for all envelopes, and the INVESTMENT HISTORY window
shows information for each envelope created.
You can create envelopes and set envelope options in the investment section in the exact same way as in the
budget section. See the Working With Envelopes help section for more information.

At the top of the investment window the program displays the portfolio information. This is the total for all of
your investment envelopes and the cost basis (the amount you paid). The history window shows the same
information for each individual envelope.
To work with a particular investment account double click it's envelope to open the investments history
window. When you buy shares or receive a dividend, you enter the number of shares and the price per share
for each envelope in the envelope's history window. The program computes the cost basis and records a
transaction in the history window. You can update the price per share for an envelope at any time which will
cause the program to compute the current market value for that envelope.
To set up your Asset Allocations Click the Asset Allocations button.
Note: When selling shares, the program uses the number of shares sold multiplied by the average price per
share to determine the cost basis.
Warning: The investment section of Budget is intended to give you a simplified means of tracking your
investments and is for reference only. The investment section is not intended as an official means of
reporting profit or loss to the IRS or any other tax agency.
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Buying and Selling Investments
Buying and selling shares of an investment account can be done at any time.
Note: Reinvested dividends should be recorded as bought
shares.
To record the buying or selling of shares use the Tools > Investment menu command to display the
investment accounts window. Then either double click the envelope, or select the envelope and then use the
Envelopes > Envelope History command.

Click either the BUY or SELL button on the investment history window, or use the Transactions > Buy
Shares... or Transactions > Sell Shares... menu command. The "Share Sell / Buy" window will be displayed
with either "Buy" or "Sell".

1. The program places the current date in the DATE field. You may change this if desired.
2. Enter the number of shares purchased in the # OF SHARES field. The program supports numbers with
up to 3 decimal places.
3. Enter the price per share in the SHARE PRICE field.
The button with the small currency symbols on it is the QUICK CONVERT popup menu. Click and
hold on the button to select a currency conversion. The AMOUNT field will be multiplied to the
correct amount in the selected currency. You can set up the quick convert menu and the rates used in
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the Currency Converter window.
4. Check the "Reset (Conversion)" box to reset the total number of shares and price per share. This can
be used in the event the investment has been converted to a different baseline. This action is similar to
starting a new investment basis at this transaction.
5. When you have all the information entered, click the RECORD button to complete the transaction and
return to the investment window.
Note: When selling shares, the program uses the number of shares sold multiplied by the average price per
share to determine the cost basis.
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Updating the Price per Share (PPS)
Updating the share price can be done at any time.
To record price per share updates use the Tools > Investment... menu command to display the investment
envelopes window. Select the particular investment envelope then use the Envelopes > Show History menu
command.
Enter the current price per share in the SHARE PRICE field and click the SET button. A new transaction
record is created with the updated information.
Note: The main investment envelope window indicates when ALL the envelopes price per shares were
updated. Until all envelopes have their price per share updated, the main investment window market value
reflects the the total of all envelopes latest information entered.
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Asset Allocation
To setup your investment allocations use the Tools > Investment menu command to display the investment
accounts window and then click the Asset Allocations button. The Asset Allocation window will be displayed.

Click the Add button to add a new investment allocation. Double click the name or Target Percent to change
them. The total of the percents for all allocations must equal 100%. You will see a warning message if the
total is not 100%.
The Target Allocation pie chart is set according to the target allocations you set in the table at the top. The
Current Allocations pie chart is set based on the current value of all your investments that have their asset
allocations set. To set the Allocations for each investment use the main investment window and double click
the investment. The investment window will open. Use the Asset Allocation button to show the drawer.

Double click the allocations percent column to set the correct allocation for this investment. The total of the
percents for all allocations must equal 100%. You will see a warning message if the total is not 100%. When
the total equals 100% the investment will be used as part of the total on the main Asset Allocation window.
Note: You can also set the asset allocations for a standard bank account by setting the checkbox. Check
the checkbox to actually use them as part of the current allocation.
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Savings Calculator
The Budget program provides a savings calculator to help you determine how much money you can save. To
show the calculator, use Tools > Savings Calculator.

Enter or change any of the fields to determine the final amount. The STARTING AMOUNT is your current
balance. The ADDED MONTHLY is the amount you are putting in each month. The INTEREST RATE is
amount of interest from the bank you are getting on the amount and is entered as a percent (i.e 5.25 is 5 and
1/4 percent). The INFLATION RATE is your estimate of how well the economy is doing and is also entered as
a percent. The NUMBER OF MONTHS is how long you want to be saving.
Any number except the NUMBER OF MONTHS can be zero. The NUMBER OF MONTHS must be at least
one.
Interest calculation is compounded monthly, and the inflation factor is computed yearly.
Note: You can select an envelope or envelope group before starting the calculator to use the amounts
defined in that envelope. The balance of the envelope will be placed in the STARTING AMOUNT field and
the amount allocated monthly to the envelope will be placed in the ADDED MONTHLY field.
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Sync with iPhone or iPod Touch
Sync the current Budget data file with an iPhone or iPod Touch running the "Budget Touch" software from
Snowmint Creative Solutions. Requires a wireless network connection to your desktop machine.

In Budget Touch
Start Budget Touch on the iPhone or iPod Touch. Touch the Actions button. In the Actions screen touch the
"Sync Data" button. The name of your device will be displayed and the status line will show "Waiting for
connection".

In Budget
Use the File > Sync with Budget Touch menu command. The name of your iPhone or iPod Touch should
appear in the Devices table. Select it and the "Sync With Device" and "Push To Device" buttons will be
enabled.

Sync
Enter your password if you set one for Budget Touch. Click the "Sync with Device" button to start the sync
process. The Budget Touch date file will be brought into Budget on the desktop. Budget reads the devices
data file, syncs the file with the desktop file, sends the entire desktop file to Budget Touch, and reports the
results. If there are any errors you can click the "Errors" tab to display them.

Push
Click on the "Push To Device" button to push the current desktop file to Budget Touch without syncing. The
Budget Touch data file will be replaced with the current desktop file. Budget will ask you to confirm the push
so you don't accidentally replace your Budget Touch data.

The Sync Process
Once communications are established between the desktop version of Budget and Budget Touch running on
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the iPhone or iPod Touch the following process is followed.
1. Initial check for errors.
2. Any new accounts created in Budget Touch since the last Sync or Push are added to the desktop data
file. The Account settings are checked in both Budget and Budget Touch and the latest change is
preserved.
3. Any new envelopes created in Budget Touch since the last Sync or Push are added to the desktop data
file. The Account settings and expense information are checked in both Budget and Budget Touch and
the latest change is preserved.
4. Any new transactions created in Budget Touch since the last Sync or Push are added to the desktop
data file with the following restrictions. If either condition is not met, the transaction will not be added
to the Budget desktop file.
❍ Both the account and the envelope for every transaction must be present in the Budget data file.
❍ For split transactions every envelope referenced in the split transaction must be present in the
desktop Budget data file.
5. Any new Pay's created in Budget Touch since the last Sync or Push are added to the desktop data file
with the following restrictions. If either condition is not met, the pay will not be added to the Budget
desktop file.
❍ The account for the pay must exist in the desktop data file.
❍ Every envelope referenced in the pay must be present in the desktop Budget data file.
6. Once all accounts, envelopes, and transactions have been added the entire Budget Touch file is
replaced with the desktop Budget data file. A sync report will show the number of accounts,
envelopes, and transactions added. Any transactions not added will be listed in the Errors tab.
Accounts, envelopes, and transactions, created in Budget Touch can be edited or deleted. However, once
transactions are synced with the desktop they can no longer be edited or deleted in Budget Touch. Envelopes
or Accounts synced with the desktop can not be deleted in Budget Touch nor can the group sub-envelope
relationship be changed. However, envelopes settings may be modified.
Note: If you have an account or envelope in the desktop and create another account or envelope in Budget
Touch with the same name, they are considered different accounts or envelopes. If you want the same
account or envelope on Budget Touch that exists on the desktop "Push" the desktop file to Budget Touch.

Errors Tab
If any errors are detected the sync is halted and the Errors tab is displayed.
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●

●
●

●

Error 1 - The Budget Touch transaction (standard or split) is in a bank account which is not present in
the desktop.
Error 2 - The Budget Touch standard transaction is in an envelope which is not present in the desktop.
Error 3 - The Budget Touch split transaction has at least one part of the split in an envelope which is
not present in the desktop.
Error 4 - The Budget Touch pay has at least one part of it's distribution to an envelope which is not
present in the desktop.

Clicked the "Terminate Sync" button to stop the sync with no changes made to the Destop file. Click the
"Continue Sync" button to continue the sync with the valid data. The transactions listed in the error report
will not be synced.
Warning: Transactions that did not contain errors are added to the desktop file. Transactions that are
reported as errors are not added to the desktop file. Consequently, if the desktop file is sent to Budget
Touch the transaction that had errors will be gone, transactions that were synced without error will be
present. If you want the transaction that had errors you must enter it correctly in Budget Touch, or Budget
and re-sync.

Log Tab
The log tab shows a running log of all additions or changes made during the sync process.

General Usage
Budget Touch can be used stand alone with no issues. To use it with the desktop there are three possible
situations:
1. Existing Budget user - Not using Budget Touch previously. Has existing Budget data file with
accounts, envelopes, and transactions. Open the desktop file and "Push To Device" to start using it in
Budget Touch also.
2. Existing Budget Touch user - Not using Budget previously. Has existing Budget Touch data with
accounts, envelopes and transactions. In Budget, create a new empty file by using the File > New
menu command and cancelling the Setup Assistant. On first sync all items in Budget Touch are
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considered new when compared to the empty desktop file. All are added to the desktop file, and then
the entire desktop file is sent to Budget Touch.
3. Ongoing use of both Budget Touch and Budget. New items in Budget Touch are added. Any new
items added to the desktop are already in the file when it is then sent to the Budget Touch.

Issues
●
●
●
●

Accounts - Once synced can not be deleted in Budget Touch.
Envelopes - Once synced can not be deleted in Budget Touch.
Pays - Once synced can not be deleted in Budget Touch.
Transactions - Once synced can not be modified or deleted within Budget Touch.
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Importing QIF and OFX files
Note: QIF and OFX files are text files that provide a means to transfer financial information from a bank
or other financial software to wherever you want. This allows you to reconcile your Budget data with your
bank, or to convert from a different financial application to Budget. However, not all data contained in QIF
and OFX files is compatible with Budget. Budget currently only supports standard bank transactions such
as checks, debits, deposits, and credit card charges and payments.

To import a QIF or OFX file, use the File > Import QIF/OFX... menu command, or use the Import QIF/
OFX toolbar button on the main window. You will then see the standard file open window where you can
choose which file to import.
Budget will process most of the imported file in the background while you are reviewing the Import
Progress and Options window. Once you click the Import button, Budget will finish processing the
imported data and then display the Import Matching window. You can click Cancel to not continue with
importing the file.

File Import Options

When importing a QIF file the Import Progress and Options window has two tabs: one for setting the date
format and one for setting the currency format. This is needed because the data in a QIF file can be formatted
differently based on where the QIF file was generated.
Both formatting tabs work in a similar way. A text sample from the imported file is displayed at the top of the
tab. Below that is a text field where you should make the correct entry based on the format used in the
imported file. Below your entry is the same sample text which has been processed with your formatting.
You need to tell Budget what format the dates and currencies are in the file. Banks all over the world use all
sorts of different formats, so you need to let Budget know what to interpret as digits as well as the constant
text before/after/between the digits.
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Example: Look at your downloaded file in a text editor. If the dates in the file are of the form 20091109,
then set the text in the Date Format field to YYYYMMDD. That means the four digit year is first, then
two digits for month, then two digits for day. If the dates in the file are of the form 28/07/2009, then set the
text in the Date Format field to DD/MM/YYYY. That is two digits for the day, then a slash, then two
digits for the month, then a slash, then four digits for the year.
When importing an OFX file the Import Progress and Options window simply displays the progress bar.
You don't need to decide any formatting because OFX files contain data formatted the same way no matter
where the OFX file was generated.

Configuring Import Rules
You can setup rules that define how your data will be imported into Budget. See the section Import Rules for
more information.
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Imported File Matching/Recording
After importing a file the transactions in the file can be matched to existing transactions in Budget. If a
particular transaction has not yet been entered in Budget, a new transaction can be recorded that uses the
imported transaction as it's basis.
Note: You can record new transactions from imported transactions. See Recording new transactions below
for more details.

The goal of the Import Matching window is to match all relevant imported transactions to transactions
recorded in your data file. When you close the Import Matching window, matched transactions will be
marked as reconciled in the Balance window and all unmatched imported transactions will be discarded.

The Import Matching window contains a table of the imported bank transactions. The columns for ID, Paid
To/Received From, and Memo are all optional and may not appear if no data of that type was imported.
You can sort the table by clicking in the column headers for imported data.
Filtering what is displayed
At the bottom of the window are four buttons that control what is displayed in the table.
●
●
●

●

All - all imported transactions are displayed.
Matched - displays all imported transactions that have been matched to transactions in your data file.
Unmatched but Assigned - displays all imported transactions that have not been matched but that do
have both an assigned envelope and an assigned bank account.
Unmatched & Unassigned - displays all imported transactions that have not been matched and that
have no assigned envelope and/or bank account.
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Matching previously recorded transactions
When an imported transaction has a match, the matching transaction's bank account and envelope are shown
in the Bank Account and Envelope columns respectively.
Automatic matching
Budget attempts to automatically match imported transactions to previously recorded transactions. This
matching is based on transaction type, amount, date, and the check ID (if given). The overall transaction type
of withdrawal (Budget's check, debit, ATM, or charge transactions) or deposit (Budget's deposit or pay
transactions) must match. Amounts and check IDs (if given) must also match exactly. The date of the
imported transaction is used to determine a window of time to allow the match.
If no matching transaction is found, Budget will attempt to assign the transaction to an existing envelope for
recording. Budget looks at the imported "Pay To/From" and "Memo" fields for names of envelopes. If an
envelope name is found in either of those fields that envelope is set as the assigned envelope for the
transaction. See the section Assigning envelopes and bank accounts below for more information on assigned
envelopes.
You can run the automatic matching algorithm at any time by clicking the Auto Match button. To achieve a
stricter or looser match, you can specify the number of days on either side of the imported transaction's date
in order for the dates to match.
Manual matching
If Budget's automatic matching fails, you can assign matches manually. Select one or more imported
transactions in the table, then click the Find Match... button. This will display the Find Match window where
you can perform detailed searches of your previously recorded transactions to find a match for the selected
transaction(s).
Note: You can see a description of the matched transaction by hovering the mouse cursor over a matched
imported transaction.

Breaking a match
If Budget's automatic matching finds the wrong transaction, you can break the match by turning the checkbox
off in the Match column for the imported transaction. This will leave the assigned envelope and bank
account the same, but the imported transaction will no longer be matched to a recorded transaction.

Recording new transactions
Assigning envelopes and bank accounts
When there is no matching transaction, you can choose what bank envelope to assign an imported transaction
using the relevant popup menu in the table. If you have multiple bank accounts in your document you can
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also choose what bank account to assign an imported transaction using the relevant popup menu in the table.
The assigned envelope and bank account are used when recording a new transaction.
After choosing an envelope for assignment, Budget will look at all of the unassigned transactions in the table.
If there are any similar transactions, Budget will ask if you want to assign all of those similar transactions to
the same envelope.
Example: If you have multiple transactions with a "Pay To/From" field of "Barnes & Noble" and you
select the "Books" envelope for one of them you can quickly assign the "Books" envelope to all of those
transactions without having to assign it for each individual one.
If the imported transaction has split information the envelope assignment popup will show "Split (Multiple
Envelopes)" you may selected a single envelope to create a new single envelope Budget transaction.
Likewise, if there is no split information in the imported transaction you may select "Split (Multiple
Envelopes)" to split the transaction to multiple envelopes.
Recording the transactions
Select one or more imported transactions in the table that have an assigned envelope and bank account, then
click the Record New... button. If more than one transaction is selected you will be given the choice of either
recording the transactions as assigned or displaying the transaction editor for each of the selected transactions.
If you select a single imported deposit transaction, you may be able to record that deposit as a pay
transaction. The single deposit must be assigned to the same bank account that the pay source pays into, and
must match the amount of the pay source. If both these conditions are met, the As Pay checkbox will be
enabled. Turn on the As Pay checkbox and then click the Record New... button to display the pay entry
window.
If you have one or more deposit rules defined and select a single imported deposit transaction, you can record
that deposit using a rule set. Turn on the Using Deposit Rules checkbox and then click the Record New...
button to display the deposit rules window.
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Manual matches for imported transactions

The top section of the match window shows the bank account and envelope you are searching. The number
and amount of the imported transaction(s) you are trying to match is shown in the top information message.
The number and amount of the Budget transaction(s) you have currently selected to match the imported
transaction(s) is shown in the second information message.
The envelope's transactions are shown in the table at the bottom of the window. You can restrict the number
of transactions shown by using the date range or search field. By default the balanced Budget transactions are
not shown. To display them uncheck the Hide Balanced box.

Matching imported transaction(s) with Budget transaction(s).
Find the Budget transaction(s) that matches the imported transaction(s) in the table and check the box on the
left. When the amount of the imported transaction(s) matches the amount of the Budget transaction(s), shown
in the information messages at the top, the Match button will be enabled. Click the Match button to match
the transactions and return to the Import Matching window.
Note: If the Budget transactions you are trying to match are in more than one envelope, click on the
envelope at the top right to display a popup menu that allows you to switch envelopes. Continue checking
any Budget transactions that apply.

Page 130 of 152

Configuring Import Rules
You can create simple rules to help determine how your imported QIF/OFX data will be set to use your
envelopes and accounts during the import process.
Click the Account tab to display the settings for accounts.

Click the Add Criteria button to add a new criteria. Enter any string of characters that is in the account
information in the QIF/OFX file. Use the selector to set if you want an exact match or if the characters are
just part of the import data. Set the Budget account you want to be used if the import file has the matching
account information. Set the bank account you want to use if there is no matching information for each type
of bank account.
Click the Envelope tab to display the settings for envelopes.

Note: the section only applies if the imported file has category information. Click the Add Criteria button to
add a new criteria. Enter any string of characters that is in the category information in the QIF/OFX file. Use
the selector to set if you want an exact match or if the characters are just part of the import data. Set the
Budget envelope you want to be used if the import file has the matching category information. Set what you
want Budget to do with import categories that are not matched.
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Note: the section only applies if the imported file does not have category information. Click the Add Criteria
button to add a new criteria. Enter any string of characters that is in either the Paid To / Received From field
or the Memo field information in the QIF/OFX file. Use the selector to set if you want an exact match or if
the characters are just part of the import data. Set the Budget envelope you want to be used if the import file
has the matching information. Set what you want Budget to do with imported transactions that are not
matched.
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Archiving your data
Budget always keeps two years of history record data. When history records are archived they will no longer
be seen in the History window and can not be searched by the program. Archived data is placed in a standard
text file on your hard drive. It may then be viewed with any text editor such as "TextEdit". See the section on
Archive Data Format.
To archive history records, use the File > Archive menu command. If the command is disabled there are less
than 2 years of data in the history and you will not be able to access the archive window.

1. Check the box for the year(s) to archive. Each selection shows the total number of history records that
will be archived for that year.
2. When you have selected the years to archive, click the OK button to continue.
3. You will see the standard save window. Use this window to select where to save the archived data.
Save the file by clicking on the SAVE button. The program will write the data for the years selected to
individual files named for each year you selected (for example, data from 1999 would be named
"Archived data for 1999").
Note: You can not archive data if there are unbalanced transactions. If this is the case, the checkbox for
the year with unbalanced transactions will be disabled (dimmed) and you will not be able to select that
year.
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Exporting Transactions
Transaction history records can be exported for use in external programs such as spreadsheets or other
financial programs. The data may be output in any of 3 formats: tab delimited, QIF, or OXF. Tab delimited
data may then be viewed with any text editor such as "TextEdit". See the Archive Data Format topic for more
information about the tab delimited format. For information on QIF or OXF formats consult documentation
for those file types that you can find on the web.
To export transaction history records from a single envelope, select it and then use the File > Export menu
command. To export all transaction history records, make sure that no envelopes are selected.

The program will place the date of the earliest transaction history record in the FROM date field and todays
date in the TO date field. Change the FROM or TO date if desired, or leave the dates as is for all history
records.
Select the type of output format desired by clicking one of the radio buttons.
Check the INCLUDE TRANSFERS box if you want the transfer history records (transfers between envelopes
do not reflect any real world transaction) included in the output file.
Check the INCLUDE CREDIT CARD CHARGES box if you want charge history records included in the
output file.
Click the OK button to export the data, or click the CANCEL button to exit.
If you clicked the OK button, you will see the standard save window. Use this window to select where to save
the archived data. Save the file by clicking on the SAVE button.
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Archive Data Format
The Budget program can export files in text format. This makes it easy to use the data in many other
programs. The data in these files is placed in tab delineated fields within each text record to facilitate
importing the data to other programs. The data in each record is in the following format.
All records
Field 1 - Transaction type as a single letter (see below for abbreviations).
Field 2 - Transaction bank account name.
Field 3 - Envelope name, or blank for account history records.
Field 4 - Date.
Field 5 - Paid To, or Received From, or Envelope name (for Transfer)
Field 6 - Amount.
For Checks, Debits, Transfer, and Charges
Field 7 - For.
For Transfers
Field 8 - Direction of transfer (in or out of the envelope).
For Debits
Field 8 - Memo.
For Checks
Field 8 - Check Number.
Field 9 - Memo.
Transaction Types
A - ATM withdrawal
C - Check or Debit
D - Deposit
H - Charge
M - Split to multiple envelopes
P

- Pay

T - Transfer
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Budget Reports
The Budget program provides a number of reports to assist in understanding your financial situation. Reports
can be generated using the standard report form (see below) or by using the Edit > Find... menu command.
The Find Command command can be used to find any transaction using criteria you specify.
Example: You can set a criteria for a date range of 1/1/07 to 12/31/07 and one for transactions that have
been marked as "tax items" to find all your tax transactions for that year and get the total amount.
You can also get transaction reports from the History Window.
To create a standard report, use the Tools > Reports... menu command.
If you have not registered Budget, reports will be overwritten with a watermark that says "Unregistered". See
the registration topic to learn more about registering Budget.

The Reports window provides six types of reports. Select the report desired from the popup menu in the
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REPORTS window toolbar. The report will be shown in the main area of the REPORTS window. The types of
reports are:
1. The TRANSACTION report provides a listing of your transactions by account and/or envelope.
2. The OVERALL STATISTICS GRAPH report shows your total expenses and deposits for all accounts
and envelopes.
3. The BUDGET YEARLY STATISTICS report provides a listing for all budget envelopes that include the
total amount deposited and the total amount expended for each envelope for last year and this year.
4. The BUDGET STATISTICS report provides a listing for all budget envelopes that include the total
amount deposited and the total amount expended for each envelope during any given time period.
5. The INVESTMENT STATISTICS report provides information on all of your investment envelopes.
This includes items such as the number of shares and the cost basis for each envelope.
6. The INCOME DISTRIBUTION report provides the total monthly amount allocated to each of your
envelopes. It also shows the percentage of total pay allocated for each envelope.
7. The BALANCE SHEET report shows the total amount of money in all bank accounts and investments.
You can also see how the money in each bank account is broken into envelopes by using the SHOW
DETAILS checkbox.
8. The PROFIT/LOSS report shows the total amount of income (from pay sources and other deposits),
and also shows the total amount of expenses from individual envelopes.
9. The Tax report provides information on your transactions that you set as a tax item. The totals of
taxable expenses and deposits for each envelope for the date range are reported.
10. ENVELOPE BALANCES report shows the current balance of all envelopes broken down by bank
account. It also shows the total amount in the envelope for all bank accounts. The last row of the table
shows the balance of each bank account.
11. ENVELOPE ALLOCATIONS report shows the monthly total allocation in each envelope for each pay
source. Also displays the total monthly allocation for each envelope for all pay sources.
12. BANK ACCOUNT BALANCES OVER TIME reports shows the balance of each bank account (and the
total of all bank accounts) for the last day of each time period shown.
13. ENVELOPE EXPENSES: PLAN VS ACTUAL report shows the bill amount set for each envelope, the
amount of expenses actually taken from that envelope, and the difference between the two.
Note: For the Planned vs Actual view the bill amount shown for all time periods is the current bill
amount. Budget does not keep historical settings of your bill amounts.

Click the options toolbar button to set different options for each report.
To print a report, first view it in the REPORTS window. Then click the PRINT icon in the REPORTS window
toolbar, or use the File > Print... menu command..
You can save a report to a tab delimited text file. To save a report, first view it in the Reports window. Then
click the SAVE AS TEXT toolbar button. You will be prompted to name the file and choose the folder to save
it in.
You can also save a report to a PDF file. A PDF file can be viewed on many different computer platforms
using Adobe's Acrobat Reader. To save a report, first view it in the REPORTS window. Then click the SAVE
AS PDF toolbar button. You will be prompted to name the file and choose the folder to save it in.
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Budget Data Analysis
All Data Analysis reports have been moved into the Report section. See the Reports section for more details.
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Envelope Statistics
Envelope statistics provide information on how well you are keeping within your budget allocations. You can
display statistics for a single envelope (regular or investment), a group, or the entire budget. Use the
Envelopes > Statistics... menu command or click the STATISTICS toolbar button with the envelope, group,
or nothing selected. To show the statistics for an investment envelope hold the Control key and click on the
investment envelope to bring up the context menu, then select "Envelope Statistics".
Note: Statistics must be shown on a monthly
basis.
Use the date range popup to set predefined date ranges or set the starting or ending dates to any date you
want. Statistics can be shown in any of 3 ways.

Statistics shown as a line graph

Statistics shown as a bar graph
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Statistics shown as a table

Note: Showing the statistics for the entire budget (nothing selected) is a good way to determine if you are
keeping within your budget. In this case the balance line is the key since it shows the trend of your
spending. If it is staying level then you are keeping to your budget. If it is going up then you are getting
ahead. If it is going down you may want to take some corrective action.
Deposits are any money entered from each pay or any deposits made directly to the envelope. Expenses are
the total of all checks, debits and ATM's written during the month. The checkboxes for showing transferred
amounts are set based on the options set for this envelope. See the "Options" section of the Working With
Envelopes topic. You may toggle this to see the amounts transferred.
For the table view, the PERCENT column is the percentage of expenses against the amount of deposit. The
bottom two lines in the table show the total for the year and the monthly averages. Percentages above 100%
show that you have not been keeping within your budget.
The graph view also shows the monthly balance. You can use the radio buttons to select either the AVERAGE
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or CUMULATIVE balance. AVERAGE balance is the average of all transaction balances for a given month.
CUMULATIVE balance is the amount in the envelope at the end of the month that is carried over to the next
month.
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Preferences
Budget has two types of preferences. Some preferences apply to the entire application, while others apply to
each Budget document you may have. The preferences that apply to a single document are listed together in
the DOCUMENT SPECIFIC group. To set your preferences, use the Budget > Preferences... menu
command. Choose the particular set of preferences you'd like to see using the icons. You can also drag
frequently used icons into or out of the toolbar.
You can use the DEFAULT button to reset each pane's settings to the standard ones that ship with Budget.

General pane

●

●

●

●

●

●

Open most recent document on launch
Each time the Budget application is launched, open the last saved document from the previous session.
This is very useful if you are always working with the same document.
Open Calendar window when opening a document
When opening any document, show the calendar for that document. The calendar will always show
automatically if there are any overdue reminders for the document.
Show check number on first line of history
If this is set the first line of a transaction in the history window will show the check number for checks
or the tranaction type for all other transactions. Check numbers are normally shown in the second line.
Display reminder icons on main and group windows
Any reminders set for transactions in envelopes will cause a reminder icon to display in that envelope
on the main window and/or a group window. Learn more about this feature here.
Draw envelope/bank account info in bold
Toggle to draws the text within envelope and bank account graphics in bold or plain text.
Money field data entry works similiar to an ATM
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All money entry fields will work just like an ATM machine does. You will only need to enter digits
and possibly the negative sign. If this is off, money entry fields will work like any other text entry
field.
●

●

●

Initial selection is date field in transaction windows
Places the initial keyboard focus on the date field of most transaction windows. This is useful if you
find yourself changing the dates of most transactions by hand.
Show currency conversion quick convert on transaction windows.
This allows you to easily convert amounts to different currencies. You can set up the quick convert
menu and the rates used in the Currency Converter window.
International Settings
Click this button to set your preferences for the date formats and language to use. Budget uses the
System Preferences International pane to format it's data, so this will open the System Preferences
application and switch to the International pane.
After you have made changes in the System Preferences International pane, you will have to quit
Budget and launch it again to see those changes.

●

Reset Input Warnings
Click this button to reset all user input warnings when editing text fields. A typical warning is one that
tells you an amount text field only accepts numbers. These warnings have a DON'T SHOW AGAIN
checkbox so you can turn them off. Clicking this button turns them all back on.

Automatic Update pane

●

Automatically check for updates when you have a network connection
When the Budget application is launched, it can check for updates via the internet. If you do not have
an internet connection active, nothing will happen. Budget can check once per day, week, or month
when the application is launched.
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●

●

●

Include system information
If this is turned on, Budget will send additional non-personal information about your system to us at
Snowmint Creative Solutions LLC. This information will be used to help us decide what systems to
support. You can click the LEARN MORE... button to see the exact set of information that Budget will
send. If activated, this information will be collected and sent during any check for updates (manual or
automatic).
Download currency rates while checking for updates
Budget will download the latest currency rates available from the Snowmint Creative Solutions web
site during any check for updates (manual or automatic).
Check Now
Contacts the Snowmint Creative Solutions web site to check for updates immediately. You must have
an internet connection for the check to succeed.

Automatic Backup pane

Budget keeps at least one automatic backup file of your data. See the Backing Up Your Data documentation
for more information. If you have not registered Budget, only the ONE FILE BACKUP option is available to
you.
●

Single File Backup or Dated Backup Files
With SINGLE FILE BACKUP the backup file is named by adding a tilde (~) to the file name, and old
backup files are overwritten.
With DATED BACKUP FILES the backup file is named by adding the current date to the file name. A
backup file is created only once for any given date, and you will accumulate a set of backup files that
contain your data as of the beginning of those dates.

●

●

Automatic save after Balance
If this is set, Budget will automatically save your data file after you balance any bank account. You
can specify a different backup file location to place an additional copy of the saved file during this
auto-save. The normal backup file (single or dated) is also created.
Backup File Location
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You can specify the location of the backup file using this text field. If you leave this text field blank,
the backup file will be created in the same folder as the original data file. The FIND... button lets you
use the standard file chooser to navigate to a different folder to save the backup file.
We recommend keeping the automatic backup file(s) on a different hard drive from the main data file
if possible.

Icon Packs pane

With this pane you can view the icon packs that Budget is using. If you select a loaded icon pack in the table,
you will see more details about it above the table. You can click on the web site link to visit the site, or click
on the email link to start an email to the author.
You can install icon packs while Budget is running, and use the SCAN FOR ICON PACKS NOW button to
have Budget look for them. Budget automatically scans for icon packs when it is launched.
To find out more about icon packs for Budget, including how to make your own, visit our web site.

Registration pane
Use this pane to set or view your registration information. See the Registration help for more information.

Document Specific Preferences
All of the following preferences are saved with the front-most document file. If no document file is open,
these preferences are not available.
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Colors pane

The settings on this pane only apply to the front-most document.
Use this pane to set which colors the application should use to display information. Click on the color square
that you want to change to bring up the color selector. This will allow you to select a different color for each
setting.
To change the color of one particular bank account or envelope follow these steps.
1. Select the bank account or envelope.
2. Click the INFO toolbar button.
3. Set the color on the APPEARANCE tab of the info window.

Currency pane

The settings on this pane only apply to the front-most document.
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Use this pane to set what currency symbol and number format the application should use to display
information. Your changes are reflected live in any open windows of the front-most document.

Interface pane

The settings on this pane only apply to the front-most document.
●

●

●

Place N transactions in "Pay To/Received From" pop up menu.
You can set the number of previous transactions for Budget to display in the pop up menu when
recording a new transaction. Only transactions matching the same type, bank account, and envelope
(s), are added so there's usually no need to go much beyond five.
Use AutoComplete in "Pay To/Received From" field
If this is set, Budget will attempt to auto-complete typing in the PAY TO or RECEIVED FROM field
to one of the previous transactions or an Address Book entry (see below).
Reset
Clicking on this button will remove all transactions from Budget leaving only the accounts and
envelopes with zero balances.

Address Book settings: These settings are only enabled when running on Mac OS X v10.2 and later.
●

●

●

Use Apple Address Book
If this is set, you will be able to add or change entries in Apple's Address Book when recording
transactions. You can click the small book icon next to any PAY TO or RECEIVED FROM field to
edit the given Address Book entry.
Add Address Book Entries to "Pay To/Received From" Pop Up Menu
If this is set, Budget will scan the Address Book and add all companies and people names to the
relevant pop up menu. This can be convenient if you store all the people and places that you interact
financially with in the Address Book.
Create "Budget" Group in Apple Address Book
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If this is set, Budget will create a new group (or use an existing group) with a name of "Budget" in the
Address Book. Any new entries created by Budget will be placed in this group.
●

Only Use "Budget" Group Entries in Pop Up Menu
If this is set, Budget will only place Address Book entries that are in the "Budget" group into the
transactions PAY TO or RECEIVED FROM pop up menu. This allows you to not see all of your other
Address Book entries.

iCal settings: These settings are only enabled when running on Mac OS X v10.2 and later.
●

Update iCal when creating, recording, or deleting Budget reminders
If this is set, any changes made to Budget reminders will be propagated to iCal automatically. This
will launch iCal if it's not already running. You can also sync with iCal manually by using the
Calendar window.
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Print a Check or Debit
Checks may be printed by selecting the check to print in the history window and clicking on the PRINT
toolbar button. You may also print the check when you write it by clicking the RECORD & PRINT button
instead of the RECORD button in the check transaction window.
In order to print checks you must have a printer that is able to hold your bank checks. Most ink jet printers
and some laser printers are adjustable to different size paper. Once you have verified that your printer can
hold your checks, you must tell the program which fields to print and where to print them. Field defaults for
standard sized checks are already set and may only need minor adjustments for your printer.
To set up your checks for printing, first select a bank account on the main budget window, then use the
Accounts > Check Print Setup... menu command to display the CHECK PRINT SETUP window. The
window has default settings to print the payee, amount, for, memo, and date (day month year) for standard
size US personal checks.
Note: Each bank account has it's own check printing
settings.
If you have not registered Budget, printed checks will be overwritten with a watermark that says
"Unregistered". See the registration topic to learn more about registering Budget.

The position of the field in the window is the location that the field will be printed on the check. Checking a
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field's checkbox places that field in the default position on the check. Clicking within a field rectangle allows
you to drag the rectangle. Clicking on a knob of the rectangle allows you to adjust the size of that rectangle.
Selecting the checkbox CURRENCY SYMBOL prints the local currency symbol with the amount.
For fine adjustments you can use the arrow keys to move the selected field.
To print, select a check in an envelope's history window and use the File > Print... menu command. We
suggest that you print a few checks on plain paper to verify that the fields will be printed in the correct
locations on your check.
You can set the number of the next check in your checkbook here as well.
To have Budget print your signature on your check you must have an image of your signature. Create a
picture of your signature by using your scanner and the software provided with that to create an image file.
From the check print setup window click the BROWSE button to navigate to your image file, or drag the file
to the image well. Select the SIGNATURE checkbox and position the field on the check.
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Register Budget
To enter your registration information, use the Budget > Enter Registration Code... or the Help > Enter
Registration Code... menu command.
If you have an internet connection and a credit card, you can purchase Budget directly within the application
itself. Click on the BUY NOW! button to start the purchasing process. You will be lead through the steps
necessary to purchase the software, and activate the registration code.
You can also purchase Budget on-line from the Snowmint web site at http://www.snowmintcs.com/store/.
Shortly after you have completed the purchase, you will receive an email with the registration code and user
name to enter in the Budget application.

Enter the registration NAME and CODE exactly as specified in the email you received after purchasing
Budget. The fields are case sensitive.

Price
US$ 29.95 for download edition, or US$ 37.95 + S&H for CD
Volume pricing and academic pricing are available by contacting sales@snowmintcs.com.

What Do I Get For Registering?
●
●
●
●

Lifetime upgrades of Budget. See the Snowmint web site for more information.
No more nag screens when launching or quitting Budget.
Removes the "Unregistered" text on reports and printed checks.
The capability to export history data.
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●
●
●
●
●
●

The Find Transaction... command will have unlimited number of criteria instead of only one.
An unlimited number of investment envelopes (without registering you can only create three).
Additional backup options available in the Preferences window.
Perform an unlimited number of transactions on each budget envelope.
Documentation in PDF format suitable for printing.
The satisfaction of supporting a small company creating quality software.
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